Support » Plugin: Multiple Featured Images » Installed, added code to functions.php, 2nd featured image not showing UI in pos

  • I’ve installed the plugin and activated it, I added the PHP code to the WordPress child theme, however, the option to add a second featured image doesn’t appear on posts.

    I’m using WordPress 4.9.10 running Bare bones for Divi theme.

    Are there compatibility issues, or any additional steps required?

Viewing 2 replies - 1 through 2 (of 2 total)
  • Update: I had missed this:

    'post_type' => array( 'page' ),

    Changing that to this:

    'post_type' => array( 'post' ),

    Exposes the UI to upload a 2nd Featured Image, so that works.

    The problem now is in using the Shortcode: [kdmfi_featured_image id=”featured-image-2″ size=”full”]

    If I embed that shortcode in a post, the image doesn’t display.

    Hi,

    I have a similar problem with my elearning theme….
    I am trying to have a second featured image in the course custom posts…

    I have installed and activated the plugin…. I have added the following code in functions.php in both my theme folder and child theme folder :

    add_filter( 'kdmfi_featured_images', function( $featured_images ) {
      $args = array(
        'id' => 'featured-image-2',
        'desc' => 'Your description here.',
        'label_name' => 'Featured Image 2',
        'label_set' => 'Set featured image 2',
        'label_remove' => 'Remove featured image 2',
        'label_use' => 'Set featured image 2',
        'post_type' => array( 'post' ),
      );
    
      $featured_images[] = $args;
    
      return $featured_images;
    });

    But when I edit a course, I dont see anything below the existing feature folder uploader area on the right sidebar… Am I doing anything wrong ?

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Installed, added code to functions.php, 2nd featured image not showing UI in pos’ is closed to new replies.