WordPress.org

Support

Support » Installation » [Resolved] Installation Stuck at Step 2 WordPress 1.5.2

[Resolved] Installation Stuck at Step 2 WordPress 1.5.2

  • shenxiang89

    @shenxiang89

    I have a Mandrake 10.2 server… uses:
    Apache 2.0.55
    MySQL 5.0.15
    PHP 5.0.5

    I have a problem during installation, that is at step 2… the installation was stuck showing this ::

    WordPress
    Second Step
    Now we’re going to create the database tables and fill them with some default data.

    Nothing Else…
    I checked phpmyadmin there were 9 tables created… how do i go about solving this problem?

Viewing 9 replies - 1 through 9 (of 9 total)
  • jefflundberg

    @jefflundberg

    shenxiang89

    @shenxiang89

    It still had the same error… the tables are created but installation still stopped at Step 2… i am really puzzled…

    shenxiang89

    @shenxiang89

    Taking a closer look at wp-admin/install.php

    Starting from line 159

    // First post
    $now = date('Y-m-d H:i:s');
    $now_gmt = gmdate('Y-m-d H:i:s');
    $wpdb->query("INSERT INTO $wpdb->posts (post_author, post_date, post_date_gmt, post_content, post_title, post_category, post_name, post_modified, post_modified_gmt) VALUES ('1', '$now', '$now_gmt', '".addslashes(__('Welcome to WordPress. This is your first post. Edit or delete it, then start blogging!'))."', '".addslashes(__('Hello world!'))."', '0', '".addslashes(__('hello-world'))."', '$now', '$now_gmt')");

    $wpdb->query( "INSERT INTO $wpdb->post2cat (rel_id, post_id, category_id) VALUES (1, 1, 1)” );

    // Default comment
    $wpdb->query(“INSERT INTO $wpdb->comments (comment_post_ID, comment_author, comment_author_email, comment_author_url, comment_author_IP, comment_date, comment_date_gmt, comment_content) VALUES (‘1’, ‘”.addslashes(__(‘Mr WordPress’)).”‘, ”, ‘http://wordpress.org’, ‘127.0.0.1’, ‘$now’, ‘$now_gmt’, ‘”.addslashes(__(‘Hi, this is a comment.
    To delete a comment, just log in, and view the posts\’ comments, there you will have the option to edit or delete them.’)).”‘)”);

    // Set up admin user
    $random_password = substr(md5(uniqid(microtime())), 0, 6);
    $wpdb->query(“INSERT INTO $wpdb->users (ID, user_login, user_pass, user_nickname, user_email, user_level, user_idmode, user_registered) VALUES ( ‘1’, ‘admin’, MD5(‘$random_password’), ‘”.addslashes(__(‘Administrator’)).”‘, ‘$admin_email’, ’10’, ‘nickname’, NOW() )”);

    // installation stopped here… (admin user was created as shown in database)

    $message_headers = ‘From: ‘ . stripslashes($_POST[‘weblog_title’]) . ‘ <wordpress@’ . $_SERVER[‘SERVER_NAME’] . ‘>’;
    $message = sprintf(__(“Your new WordPress blog has been successfully set up at:

    %1\$s

    You can log in to the administrator account with the following information:

    Username: admin
    Password: %2\$s

    We hope you enjoy your new weblog. Thanks!

    –The WordPress Team
    http://wordpress.org/
    “), $guessurl, $random_password);

    download this file.
    http://www.moiza.org/upgrade-schema.zip (1 week available)
    (if download failed, try again.)

    extract wp-admin/ (already file existed, overwrite file)

    drop all tables related with WordPress.
    then, try install again.

    good luck 🙂

    Postscript)
    I’m korean. sorry my poor English.

    shenxiang89

    @shenxiang89

    arghhh… it is still the same… i dont know whats wrong…

    p.s: your english is good…

    well, let me see…
    this is so strange ^^;
    in my case, it running well.

    Microsoft IIS 6.0
    PHP 5.0.5
    MySQL 5.0.15

    I tell you something that I think special.
    1. PHP
    – character set is UTF-8
    – register_global = off
    – php extensions ( mbstring, gd2, mysql are activated)

    2. MySQL default-character-set is utf8
    3. each table of WordPress property.
    – all the tables type = innodb
    – all the tables collation = utf8_general_ci

    I’m sorry It does not helpful to you.

    shenxiang89

    @shenxiang89

    PROBLEM SOLVED…

    I didnt know what made it work… but i changed this part
    $message = sprintf(__("Your new WordPress blog has been successfully set up at:

    to
    $message = printf(__("Your new WordPress blog has been successfully set up at:

    Thus, the words displayed become unformatted… but it works

    O thanks SHENXIANG89, it works now

    I had the same problem. It turns out I didn’t have sendmail installed. The install script failed on the wp_mail function call right after the sprintf statement, which calls the PHP mail function. I had to install sendmail, then recompile PHP, then recompile Apache.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Resolved] Installation Stuck at Step 2 WordPress 1.5.2’ is closed to new replies.
Skip to toolbar