Multisite Language Switcher
[resolved] Installation resulted on "Fatal Error" and damage to dashboard (7 posts)

  1. DanMo2013
    Posted 3 years ago #

    I have been trying different plugins to provide translation options to my visitors.

    I have tried half a dozen of them.I have 'activated' and 'deactivated' about 6 of them so far.

    I tried this plugin: Multisite Language Switcher
    and it triggered a "Fatal error". I went off to read about how I need to have a multisite etc etc.

    But I had a bunch of browser tabs open and I accidentally requested Multisite Language Switcher to install again. This resulted on a more serious error: (see message below):

    ............. Error message ................................
    Fatal error: Call to undefined function json_last_error() in /home/content/c/a/m/campello/html/wordpress/wp-content/plugins/wcm-user-language-switcher/wcm_lang_switch.class.php on line 249

    I can see the left navigation of my Dashboard area but the content area only displays the fatal error notice. None of the left navigation items appear. Only the fatal error.

    Basically, I can't do anything with the blog. I can't see or edit posts through the admin. To make matters worse, my automatic backup is kicking in 20 minutes from now. I suspect this damaged version of the admin will be backedup.

    The actual blog: http://DanMontano.com is still up and running but the top admin bar is now gone.

    Can someone please advice how to fix this?
    Thank you in advance.


  2. DanMo2013
    Posted 3 years ago #

    My apologies. I looked at the error URL and noticed it mentions WCM Language Switcher, which is another plugin.

    Another user who installed that same plugin 1 month ago requested help but no one has helped him: http://wordpress.org/support/topic/fatal-error-json_last_error-1?replies=2

    At this point I'm am not optimistic about receiving help from the developers but I'm hoping they come through.

    I wish they were as responsive as realloc is.

    I know it's not your plugin but if there's any chance you may be able to help...I'm all ears.

  3. Dennis Ploetner
    Plugin Author

    Posted 3 years ago #

    You could try to remove this plugin via FTP and then return to /wp-admin/plugins.php for a "reset".

    There was a response of one of the developers. Seems on your host is PHP 5.2.x installed, right? This should be no problem with WordPress itself but with the there plugin.

  4. DanMo2013
    Posted 3 years ago #

    The developers have started to look at the issue. Please feel free to delete this thread.

  5. DanMo2013
    Posted 3 years ago #

    Just refreshed and saw your reply.

    I am running php 5.2.17

  6. DanMo2013
    Posted 3 years ago #


    Once again, thank you so much for your quick response and advice.
    Rather than delete the plugin via FTP I renamed the folder and that did "reset" the blog back to normal.

    I'm not used to digging into the "guts" of my blog, so to me this was a big issue. It's nice to know that these issues can be resolved easily.

    Thank you.
    Send me an email if I can do something to return the favor. My contact info is on my website or via Facebook / Twitter.

  7. Dennis Ploetner
    Plugin Author

    Posted 3 years ago #

    You're welcome. It would be nice if you would rate my plugin (if you tried the Multisite Language Switcher already - of course).


Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Multisite Language Switcher
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic