Support » Plugin: Ziggeo » Installation questions

  • Resolved beachcalsix

    (@beachcalsix)


    Hi,
    I am trying ziggeo out and from what I see that works, I like it a lot!
    I’m having some issues though.

    I am integrating with gravity forms and trying to restrict it to record video only. I’d also like the form to be unable to submit unless they record their video. I have been unable to customize anything and am probably doing something wrong.

    The only thing that works is the generic recorder and uploader. None of the templates work for me.

    Is this possible with a free plan?

    Thanks

Viewing 15 replies - 1 through 15 (of 20 total)
  • Plugin Author BaneD

    (@baned)

    Hi beachcalsix,

    All of our WordPress plugins are made to not be specific / limited to any plan, so it will work regardless of the plan you grab.

    I do want to mention that our core plugin does not include the Gravity Forms integration, and instead we offer this through simple bridge plugin that can be found here: https://github.com/Ziggeo/ziggeo-video-for-gravity-forms

    The core plugin offers most of the code, while these bridge plugins then add something specific to it, like in this case the code for Gravity Forms (so you need both “Ziggeo” and “Ziggeo Video For Gravity Forms”)

    If you add this other plugin, you will immediately see the Ziggeo Fields section in Gravity Forms builder. Within this new section you will see several different fields. This plugin has the hooks and classes needed to make everything work right.

    * Please do note that the plugin is only available through Github for now.

    If you prefer, you could use HTML code and the Gravity Forms HTML field to add the integration directly, however the above plugin is going to make things easier to set up if you are not familiar with the code.

    Do check it out and let us know how it goes.

    Regards,
    Bane

    Thread Starter beachcalsix

    (@beachcalsix)

    Hi, thank you!
    I did integrate everything. I see the fields in ziggeo.

    The basic video recorder/uploader is the only thing that works for me when I do form preview

    This is what I see

    When I try to do a template, there is just a blank screen. How do I add the code that can do recorder only and where do I add it?

    I found this code: <ziggeorecorder ziggeo-allowrecord=”true” ziggeo-allowupload=”false”></ziggeorecorder>

    Where do I put this code?

    Some screenshots of what I see:

    form preview just shows title and blank screen

    template area

    Is there a tutorial video or page I can read? I searched through forums a bit and looked for videos/articles but couldn’t find much. Any help is appreciated!

    Plugin Author BaneD

    (@baned)

    I would just like to mention that one image might be missing based on the text in your reply. There is “This is what I see” however nothing afterwards.

    In terms of the empty template field. It should be empty only if you do not pick the template in the Ziggeo template field. Once picked it should work and show you the template you had selected.

    Another reason why it can not show up, would be if you have the template selected and then you remove it.

    When it comes to code, like the one you have mentioned:
    <ziggeorecorder ziggeo-allowrecord=”true” ziggeo-allowupload=”false”></ziggeorecorder>

    This is HTML code and is not actual template code. You could use that however it would need to go into the Gravity Forms custom HTML field. You would then also need a hidden field that would collect the token once submitted and use one of the options to collect it (events or input-bind parameter). The Ziggeo fields however do this automatically.

    In terms of documentation such as videos there is none at this time. Let me see what we can do and have something ready on our website.

    In general what you would do is the following:
    1. Go to the templates editor
    2. Set it all up as you want
    3. Save the template
    4. Go to Gravity Forms builder
    5. Add the Ziggeo Templates field
    6. Set the “Template” option for which template to use
    7. Save the form
    8. Preview the form

    At this point you should see the recorder (or anything the template represents).

    Now with that said, the templates editor has two modes, the simple and advanced editor. The simple only has few options, while the advanced one allows you to add your own code into it.

    Since disabling uploads is not one of the more commonly used options, you would need to use the advanced editor. So copy paste this code into advanced editor field and it will create the code like you mentioned above.

    [ziggeorecorder allowupload="false"]

    * Then click save to save the template and go from step 4 above.

    As you do it should work fine for you 🙂

    Do of course let me know how it goes.

    Thread Starter beachcalsix

    (@beachcalsix)

    Wow! Thanks for the help! Now it is appearing!

    The problem now is when I hit record, it stays on the loading screen and never changes

    screen shot here:

    Is there supposed to be a pop up asking for video/audio permission and that’s why it never begins? Is it something in the settings that I haven’t clicked or a different issue?

    Here’s the template and code you gave me that I used for the template:

    Thanks again!

    Plugin Author BaneD

    (@baned)

    Awesome 🙂

    In terms of screenshots, none are shown. I am guessing that you might have replied through email and it is not showing them here.

    If you prefer you can send us an email to support@ziggeo.com. It is private communication between you and our support team, and images can be included in your email.

    In terms of permissions – yes, you should see the popup that asks you to allow camera and mic to record. If you are using a non HTTPS page, then browser can block the recorder by not allowing flash to work.

    If you are fine sharing the link here, please do, or if you are not, consider sending it in the email to the address I mentioned above.

    In general you should see this as a red icon in the URL bar (often blinking) and depending on your browser by clicking there, you will see option to allow the access to camera or Adobe Flash (only on non HTTPS).

    Thread Starter beachcalsix

    (@beachcalsix)

    I thought I linked it in the above post. Hopefully they work now.
    I just checked and there’s no red light or any indicator asking for camera permission. I clicked the little lock by the link and it says site is secure and camera and audio permission is obtained.
    Posting the screen shots here. Hope they work now:

    shows secure for recording and audio

    This is what I get when I try to record. It just loads and never starts up

    screenshot 1: frozen camera

    here’s where I put the code:

    screenshot 2: code in template

    If the screenshots still don’t work I’ll just use the email, thanks!

    • This reply was modified 1 year, 3 months ago by beachcalsix.
    Thread Starter beachcalsix

    (@beachcalsix)

    Ok, I’ve been testing a bit and the video does record on mobile.

    However, it does not save the recording. I recorded a 40 second video, hit ok when done, and nothing. Tried submitting the form and get this error message:

    error message

    Also, when I embed the form on an actual page instead of preview the form, the code doesn’t work and still allows the upload button.

    So to sum up, on desktop it won’t allow recording at all, just freezes on loading screen.

    On mobile, records, but does not save submission to form.

    Any ideas? Thanks

    Plugin Author BaneD

    (@baned)

    Thank you for the screenshots. Based on one of them: https://prnt.sc/tzqnr6 I can tell something is not parsing right on your side.

    Can you send me the link to the page over support@ziggeo.com?

    Please do reference: https://wordpress.org/support/topic/installation-questions-7/ just to connect the ticket with this right away.

    For more details as you can see
    data-is-gf="true" no_uploadtest

    It means that the field output started, however the no_upload and test got combined for some reason and these are shown because the field already got closed/finalized. This can happen in cases when something “jumps” between the start and end.

    For example when I do the same steps on my side it creates the following error:

    <ziggeorecorder data-id="input_4_1" data-is-gf="true" ziggeo-allowupload="false" ziggeo-theme="modern" ziggeo-themecolor="red" ziggeo-width="360" ziggeo-height="240" ziggeo-timelimit="120" ziggeo-rerecordable="true" ziggeo-tags="wordpress,post,post_152"></ziggeorecorder>

    By seeing the link I might be able to tell more what breaks the code and where.

    Hi, thank you for all your help and patience.

    I am wondering if this is an issue because I do not have an app token?

    Is the app token mandatory to work? I wasn’t sure and thought it was optional? I read on
    this page that the app token is found in the ziggeo account but I can’t find it. If I’m supposed to create it, how do I do that? Is this what’s causing it not to record or save? Or is it a code issue as thought?

    Thanks again and sorry for all the confusion. I’m still learning, thanks!

    Plugin Author BaneD

    (@baned)

    Hi there Karen,

    Might be good for you to open a new thread unless you and beachcalsix are working together.

    Because it seems as if you are connected based on your text, I want to mention that app token is actually important. It is like Google Analytics or Facebook Tracking token that you would place on your website. It is public info however it tells the systems about who it is.

    Just the same, the app token tells our code where to connect to – where to attempt to get the data from or where to send the data to.

    Will change the page to include a link where we explain how to get the token, the easiest way would be to follow these steps:
    1. Log into your Ziggeo account (US Region or EU Region).
    2. Click on the application you wish to use in the sidebar on the left.
    3. Click on Overview page
    4. On this page you will see Application Token.
    5. Copy that and save in the plugin settings (Ziggeo Video > Settings)

    Once added, things will start to work 🙂

    Of course as always let me know how it goes.

    Thread Starter beachcalsix

    (@beachcalsix)

    Oh wow, sorry yes, that is my partner’s account. I thought I switched back. whoops.

    I see, I will set up the token. I think this is probably the reasons behind function issues. Thanks again for all the help, I’ll let you know if it works!

    Thread Starter beachcalsix

    (@beachcalsix)

    Ok, I went through the quickstart process on my dashboard page through ziggeo and got an application token auto-generated. It asked for me to select an application but there were no applications listed so I clicked “start”.

    Next step, it auto-generated a token and I copy-pasted it in the WordPress plugin.

    Now when you view it live, the video doesn’t come up at all. It is a black screen with the text:

    You are not allowed to access the application from this site.

    Am I supposed to create an application somehow?

    Plugin Author BaneD

    (@baned)

    Hi, OK no worries just wanted to make sure that we get everyone helped 🙂

    So in terms of the Quick Start. That is actually a way for us to show you the way everything works, and it works with you having the account and without having the account.

    Based on the error it looks like you copied our system generated (temporary) application token that really only works on our website. No worries though we are on the right track.

    Now I will copy paste the steps from above however do read bellow first then come back to them:
    1. Log into your Ziggeo account (US Region or EU Region).
    2. Click on the application you wish to use in the sidebar on the left.
    3. Click on Overview page
    4. On this page you will see Application Token.
    5. Copy that and save in the plugin settings (Ziggeo Video > Settings)

    The first step is the important one as it would allow you to get access to your account.

    Only once logged in would you be able to see your application token.

    Now to support GDPR we have fully separated regions, so you have a log in page for US side: https://ziggeo.com/signin and login page for EU side: https://eu-west-1.ziggeo.com/signin

    You would use one or the other depending on where you account was created.

    Once you log in, go to the steps above and it should allow you to find it. If not, please do reach out to us over email support@ziggeo.com (and reference this ticket), or you can also reach out to us through chat in your WordPress website by going to Ziggeo Video > Settings > Contact Us.

    * While no one might be available on the chat when you reach out, someone will reach out to you over email shortly after (do leave us your email you have used to create your Ziggeo account). We can then help you to get the application token in your account.

    Hope this helps 🙂 With that said, do let me know how it goes.

    Thread Starter beachcalsix

    (@beachcalsix)

    Ah I see, I did copy the generic token.

    Going back to my very first post, I was asking if maybe the free plan was blocking things? I have the free plan and my dashboard seems very bare. I don’t see any “application” or “overview” areas.

    Here is a screenshot:

    free plan menu

    So basically, there is a dashboard that just asks for payment, account settings, payment etc. No other option which is why I thought I was supposed to copy the generic token. It was the only one I could find.

    If this is just a problem with my dashboard, I’ll definitely email for further help.

    Or, do you think it is an issue with needing a paid plan? Is there any sort of yearly plugin purchase?

    Anyways, thank you again for all the help. You have helped a lot!

    Plugin Author BaneD

    (@baned)

    Ah OK I see. So basically we made a decision to add the payment details as the first screen because many of our customers implemented our system and started using the service while the month of free plan was still on. Due to that it happened that the service was stopped as free plan expired, and often that was important day for them. So now, this is the first thing, allowing you to smoothly progress from free trial to the paid tier you selected. 🙂

    * You will not be charged once you add the details, only once the trial expires.

    Once this is done, you will see the application called “Default” show up on the left right under the “Dashboard” and right above “Create New” and “Account” menu entries.

    Please do let me know how it goes 🙂

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘Installation questions’ is closed to new replies.