WordPress.org

Support

Support » Installation » Installation Problems: Fatal error: Call to undefined function: get_bloginfo()

Installation Problems: Fatal error: Call to undefined function: get_bloginfo()

  • I have uploaded and deleted everything to the web server several times, so I know everything is there. I am using version 1.5.1.

    I get the php error message: Fatal error: Call to undefined function: get_bloginfo() <snipped path>wp-includes/wp-db.php on line 304. I checked out the file wp-db.php and don’t understand what could be the problem.

    It might be good to note that I am installing in a subdomain, if that could make any difference.

Viewing 15 replies - 31 through 45 (of 64 total)
  • I made the classic error of doing an upgrade when very tired (2am!).

    I also got the error

    “Installation Problems: Fatal error: Call to undefined function: get_bloginfo()”

    I had simply forgotten to run the ..\ wp-admin\upgrade.php page after uploading the new files. Doh!

    I have this exact problem, but the error occurs when I’m *trying* to run wp-admin/upgrade.php – the ‘simple’ upgrade instructions are tremendously misleading, so I went to the detailed instrux. I’ve changed the wp-config-sample.php to wp-config.php and ensured that all data is correct, but receive this error on line 304 when going to wp-admin/upgrade.php. What am I missing?

    You will trip over this bug if you are having database connection problems. You can simply remove line 304 of wp-db.php, which looks like this:

    header( 'Content-Type: ' . get_bloginfo('html_type') . '; charset=' . get_bloginfo('charset') );

    With that line gone you will be able to see the real error message. Details here.

    Thanks! That did it.

    I’m a new user, clean install, and have the same problem. Like others, have checked the wp-config file for correct database name, host (localhost), etc.

    I deleted line 304 in wp-db.php and now see the “real” error msg, but am no closer to a solution.

    Does anyone have a solution other than installing a back-level version and converting?

    OK, problem solved, at least in my case.

    I had missed the step of granting permissions to my database user. This is fairly easy to miss when using PHP CPANEL because it looks like default permissions have already been granted. But the “Grant Permissions” button must be clicked to actually apply the permissions. It had been a while since I had done this, and therefore missed it.

    I hope this might help some others who are having this problem.

    I got this error too, but it was because I forgot to run “Flush Privileges” after I added the db user.

    Just remember that if you’re setting up the user manually and you have this error. I hope they make this error clearer in future versions.

    I solved the problem by replacing ‘localhost’ with the IP address of mySQL server.

    Sorry guys, I’ve tried everything, but I still get the error.

    I’m running WP 1.5.1 with MySQL 4.1.11, on Apache 1.3.33 with PHP 4.3.11 installed. On Win XP pro. I have checked my user(s) via the MySQL commandline and I can log in fine, but 1.5.1 can seem to log in unless I go in as root, with no password to localhost.

    I have tried replacing ‘localhost’ with ‘127.0.0.1’ and ‘mymachine name’ and ‘192.168.1.102’ but to no avail. I’ve made changes and restarted Apache…

    So, I’m stumped. A MySQL setup issue?

    The same error kept me trying out everything for hours. Finally found out that there was a compatibility issue with password hashing between php and mysql. According to some newsgroups it’s not very clear which version combinations of php and mysql cause the password problem.

    Try this. Login to mysql as root and set your mysql-password with the OLD_PASSWORD option like this:

    SET PASSWORD FOR 'databaseuser'@'localhost' = OLD_PASSWORD('databasepassword');

    In case you didn’t know how to create a database and a user beforehand, you can use these 2 commands within mysql first after loging in as root:

    CREATE DATABASE databasename;
    GRANT SELECT, INSERT, UPDATE, DELETE, CREATE, DROP, INDEX, ALTER ON databasename
    .* TO 'databaseuser'@'localhost';

    It worked for me and I hope it will for you.
    Good luck & peace!

    No luck so far again. I did a clean install of all three apps and now can even connect as root (although this version is running as a windows service and root has a password) . Once again I expect this may be a mysql error or even php, but since I don;t get detailed errors I don;t know.

    Help!

    Ok, the wierdness continues. I managed to get the second instance (on a different box), but I don’t know why…I tried changing some things, but it didn’t work. I tried installing MySQL 4.0.24, which installed but I never ran.

    Then, bang, I ran the script and it worked. I have know idea what I did. I also can’t repeat it on my other box (I even installed, but did not configure the earlier version of MySQL again).

    I’ve restarted everything but it can’t get to the db…although I can log in as that user from the MySQL admin…

    Have you guys considered porting to Postgres? 😉

    Any other help (like where to find detailed log messages in either MySQL or PHP) so I can figure this out would be a help.

    hey, johnnycannuk, have you tried the old_password option? Your situation really calls for this, I guess. With earlier versions of MySQL there was another way to handle passwords. It only takes one statement in MySQL to change to old_password mode. See my earlier post just before your last 2 posts.

    Yes this was the same for me, eg either using mysql228.fasthost.co.uk or 213.171.218.228. Seems like the 99% has now become more like 90%. lol

    escape,

    Thanks, that did it!

    Now, someone update the wiki with this quick.

Viewing 15 replies - 31 through 45 (of 64 total)
  • The topic ‘Installation Problems: Fatal error: Call to undefined function: get_bloginfo()’ is closed to new replies.
Skip to toolbar