Support » Fixing WordPress » installation problems

  • Resolved wil126


    I am having trouble installing WordPress. Issue: under “Installation” is the word “NONE” When I attempt to install I get this message:

    Install WordPress (2/3)

    The installation can not be completed:

    – You cannot install more than one script in the root directory of a domain.

    Click on the browser’s Back button to fix reported errors.

    I do not know how to fix this. Anybody???

Viewing 9 replies - 1 through 9 (of 9 total)
  • are you having fantastico ? Did you install any script before? If yes, then you will need to remove some files created by fantastico..

    Thank You ryans149. Yes. WordPress is contained in Fantasico. I have no idea how I can remove files from Fantastico or which ones, but Thanks for the lead. I will follow up on that and maybe, finally I can make this work.

    Thanks again.

    If you are already using root for something else, then just install wordpress in a subdirectory. See the following video for step-by-step directions.

    [link moderated]

    Thank You figaro. I appreciate the suggestion….Will study that.


    What should have been a relatively easy process to set up a simple blog site has become a confusing and mind-numbing exercise in futility. I tried installing wordpress in a sub-directory , according to: [link moderated]
    and that did work However, I believe I have discovered the root of my problem. I suspect that critical files associated with the root directory have been deleted.

    I always throw myself into a project whole-heartedly. This zeal
    enables me to do some things that amaze me, but also does not prevent me from making stupid mistakes leading to spectacular failure—I do it too often, blithely and with great enthusiasm.
    When my first installation didn’t work, I came here and learned that sometimes plug-ins are the problem. Delete the troublesome plug-ins, it was suggested, and the installation should proceed smoothly. I did that. When that didn’t work, I began to impulsively experiment, partly out of frustration and perhaps, fatigue. I am not a computer virtuoso nor am I technically sophisticated and brilliant as so many viewers here, are. I should not experiment. Never. Not ever.

    I deleted the original installation of wordpress that was associated with the root directory and now, when I have attempted to manage my site I’ve learned this:

    1. I cannot manage my site. The Webpage URL shows nothing that I can manage. Only a few files.

    2. using Core ftp lite to transfer files I see that many files that should be there on my page are not there. In, fact, under public_html there is only one file: htaccess.

    3. I cannot place the files I need to transfer to my site because I am missing the file to put them in (wpcontent.)

    4. Whatever is missing, is because of something I did.

    I do not know if this can be fixed, but I need to get back the full number of essential wordpress files . This is the challenge. Is anyone viewing able to offer a solution to this dilemna? ( please don’t tell me to take up butterfly collecting or find some other nice hobby.) I’ve got to press on. This was long-winded–sorry, but I wanted to be a little more specific. I would appreciate any helpful suggestions.


    Did you try installing the wordpress files in root? If you followed the video, then you have the files in a directory–probably called wordpress. Just move all of those files (the ones in the wordpress directory) into root. Then all you need to do is connect to your original database by entering the proper values in the wp-config.php file and you should have your original site back — minus any custom themes, plugins, or uploads…but you will have all your posts.

    Thanks very much, figaro. I do appreciate your advice; will try it.


    I tried what you recommended figaro…sort of. The problem is that wordpress seems to be stuck on the sensation that there are already scripts in the root directory and therefore, I cannot put anything else there. When initially installing wordpress, by leaving the appropriate box for specifying the directory, blank, the installation would automatically be attached to the root directory, or so I understood. Right now I cannot re-install in the root directory because I do not know how to remove any scripts left in the root directory from the previous installation(if that is what the problem is.) I also, quite honestly, do not know precisely how to move the installation that I have into the root directory without the auto-install putting it there for me. What I have done, is made a new directory called wordpress, and this almost accomplished what I need except that a visitor would have to type in http://www.domain/wordpress. This is not exactly what I require. So…. The next questions are: 1. How can I clear the scripts in the root directory so that I can move wordpress files into it and 2. How are these files moved to the root directory manually ( without the automatic-install). Anyone? Thanks in advance.



    Just a note to explain to some viewers who have had trouble installing WordPress, I have finally resolved the issue. Technically speaking, I suppose I am a Cro-Magnon—-I do not understand the intricacies of all that I do but, I am persistent and have blundered and slogged my way to success. What a learning experience! Ouch!
    Anyway, I found a post by someone who had a similar problem. Basically, I went to the file manager and found out where the files were for WordPress in Fantastico and deleted this as well as those installed_in_root.php. Then, I re-installed WordPress with no problem. I do thank you, figaro and ryans 149 for making helpful suggestions. I appreciate it.
    All the Best,

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘installation problems’ is closed to new replies.