WordPress.org

Forums

[resolved] Installation Problems (6 posts)

  1. mlanger
    Member
    Posted 9 years ago #

    Am trying to install on a Mac OS X 10.4 Tiger server.

    When I run /wp-admin/install.php, I get the following mess:

    wp-config.php file. I need this before we can get started. Need more help? We got it. You can create a wp-config.php file through a web interface, but this doesn't work for all server setups. The safest way is to manually create the file."); require_once('../wp-config.php'); require_once('./upgrade-functions.php'); $guessurl = str_replace('/wp-admin/install.php?step=2', '', 'http://' . $_SERVER['HTTP_HOST'] . dirname($_SERVER['PHP_SELF']) ); if (isset($_GET['step'])) $step = $_GET['step']; else $step = 0; header( 'Content-Type: text/html; charset=utf-8' ); ?>
    WordPress
    hide_errors(); $installed = $wpdb->get_results("SELECT * FROM $wpdb->users"); if ($installed) die(__('
    Already Installed

    You appear to have already installed WordPress. To reinstall please clear your old database tables first.
    ') . ''); $wpdb->show_errors(); switch($step) { case 0: ?>

    ReadMe documentation at your leisure.'), '../readme.html'); ?>

    I don't know what I'm doing wrong. Any ideas?

  2. Mark (podz)
    Support Maven
    Posted 9 years ago #

    That error is because the code is simply being printed not parsed. I can't recall the url but maczealots have a tutorial I believe. I'll go look.

  3. Mark (podz)
    Support Maven
    Posted 9 years ago #

  4. mlanger
    Member
    Posted 9 years ago #

    Thanks very much for this info and link. I'll give it a try today.

    Sometimes I wonder why I invested in Mac OS X Server. The apps it comes with -- in this case, Blojsom -- are so limited in customization that they're just about worthless. Someone in the Apple Server forums sent me to WordPress, and if I can get it to work, I'll use that instead.

  5. mlanger
    Member
    Posted 9 years ago #

    The MacZealots tutorial you referenced did the trick, although I had to follow the instructions twice to get it to work right. The key seems to be to install MySQL 4.0.20 after getting rid of any of the installtions that came with Mac OS X 10.4 Server. Thanks very much for the help!

  6. jstokes
    Member
    Posted 9 years ago #

    I'm having this same problem.

    However, I don't have the option of downgrading to MySQL 4.0.x, as I already have other apps running on 4.1. I've tried the "Old Password" trick with no luck.

    Any other ideas/help?

    Thanks

Topic Closed

This topic has been closed to new replies.

About this Topic