WordPress.org

Forums

installation problems... (8 posts)

  1. Anonymous
    Unregistered
    Posted 11 years ago #

    We're having a little trouble selecting the proper database for WordPress.
    Are you sure it exists?
    Your database name is currently specified as subtlef_m. Is this correct?
    On some systems the name of your database is prefixed with your username, so it would be like username_wordpress. Could that be the problem?
    WordPress Support Forums
    Is what shows up when I go to the install page. I'm being hosted on a friend's domain, so she gave me the mysql database info, and I'm pretty sure it's correct. Her domain is hosted with http://www.hostrocket.com/ , so here's the mysql and perl info on the site:
    MySQL 3.23.56
    Perl 5.6.1
    The browser I use is IE. Anyone know the problem?

  2. Matt Mullenweg
    Troublemaker
    Posted 11 years ago #

    It could be a problem with the login details, the host, or the database name. Double check all of them in wp-config.php. That's the only thing that could cause this error.

  3. NuclearMoose
    Member
    Posted 11 years ago #

    I assume you have PHP on the server as well as Perl?

  4. WillM
    Member
    Posted 11 years ago #

    You'd have some trouble finding a host that supported Perl and mySQL and not PHP. The link to hostrocket in the original post says all accounts support PHP 4.2.3.

  5. Anonymous
    Unregistered
    Posted 11 years ago #

    Thanks for the responses. I double-checked the username and password many times...since I'm not on in the main part of the domain but instead, hosted under a subdomain, should it make a difference to what the names are? Also, how do I find if the host name is localhost or not?

  6. tcervo
    Member
    Posted 11 years ago #

    Anon: some hosts refer to their MySQL server as the "database server" instead of host name. When I create a new db using the control panel for my host, they give me the name of the database server (in my case, it's "mysql"). I got a similar message the very first time I tried to install WP, but once I changed "localhost" to "mysql", it worked fine.
    Another thing to check is make sure you've created a user for the database, and are using the username/password for the database user, *not* the username/password you use to log into your host.
    Hope this helps,
    Tony

  7. Anonymous
    Unregistered
    Posted 11 years ago #

    I used Hostrocket in the past... They prepend? to the table name.. for exapmle, if you create a db named 'test', it would become something like 'host31_test'...

  8. Anonymous
    Unregistered
    Posted 11 years ago #

    I got it figured out. My host had forgotten to add the user to the database. Thanks to all of you though, for your helpful hints.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.