Support » Plugin: AnsPress - Question and answer » Installation problem PHP error

  • Hi Guys,

    I can’t use your awesome plugin because I am getting this error message when I am trying to install it.

    Parse error: syntax error, unexpected ‘[‘ in /home/beertime/www/wp-content/plugins/anspress-question-answer/anspress-question-answer.php on line 726

    My wordpress installation is running with 5.6 version of PHP.

    How could I fix that ?

    Cheers!

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Rahul Aryan

    (@nerdaryan)

    Hello,

    This is because you are using an older version of PHP. Please upgrade your PHP to version recommended by WordPress.
    You can request your host to upgrade your PHP.

    Cheers.

    Hi Nerdaryan,

    PHP 5.6 is not enough?

    I have seen you recommend 5.5 minimum for the plugin.

    Plugin Author Rahul Aryan

    (@nerdaryan)

    Disable AnsPress and then add this to you theme’s functions.php:

    $a = ['one' => 1, 'two' => 2, 'three' => 3, 'four' => 4]

    If you see same error then your server don’t support short array syntax.

    My bad, it works awesome now than I upgraded to PHP 5.6 😉

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Installation problem PHP error’ is closed to new replies.