Support » Plugin: EWWW Image Optimizer » Installation problem on NGINX webserver

  • Resolved Wanderlusters

    (@wanderlusters)


    Hi there,

    I run my own VPS with NGINX and PHP-FPM on Debian 7.

    I have not been able to get EWWW to see/use the image optimisation plugins.

    I assume this is something to do with NGINX or PHP-FPM permissions but I haven’t been able to figure it out.

    I’ve tried copying the plugins to /usr/bin but I don’t think that’s the issue as the debug log states it can see and check the files in wp-content/ewww. Also tar is installed but the plugin is not able to see that either.

    Plugin status and debug log: http://pastebin.com/HEuRQdE5

    Any help would be much appreciated.

    Cheers,

    Ben

    http://wordpress.org/extend/plugins/ewww-image-optimizer/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author nosilver4u

    (@nosilver4u)

    Did you not get a big red warning about the exec() function being disabled? Because you should have, according to your debug log. Remove exec from your disabled functions, and try again.

    Being relatively new to Linux, WordPress, php etc no I didn’t.

    That fixed it though, thank you.

    Also surely it should not have stated ‘exec(): OK’ under Plugin Status if that wasn’t the case?

    Plugin Author nosilver4u

    (@nosilver4u)

    Looks like I need to take a fresh look at the exec() detection code, something isn’t right there. Thanks for catching that bug!

    Plugin Author nosilver4u

    (@nosilver4u)

    Ok, it’s fixed in the most recent dev version. Simple tweak to the regular expression I was using.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Installation problem on NGINX webserver’ is closed to new replies.