Support » Installing WordPress » installation problem on fedora core 5

  • hi there,

    i’ve a brand new server on which i freshly installed Fedora Core 5 linux and tried to set up a wordpress. i didn’t managed to make it work, so if there are users out there that achieved to do it, i’ll be glad to hear from them. As far as i can see, it’s a PHP/MySQL probem, but here’s the story of my problems:

    – apache (2.2) comes pre-configured w/ php (5.1) support, and i installed via yum the php-mysql package. i created a MySQL (5.0) table+user for WP, and then untared the last WP tarball (2.0.2), and tried to visit the wp-install.php url. the page loads, but i only got an error message saying my PHP installation is missing the mysql module (i’m posting from the office and don’t have the message text at hand).

    – by grepping into the WP directory i achieved to get where the message comes from : wp-settings.php . there’s a pretty test to test if the module is included in php. the PHP version in FC5 is 5.1. i cheched into php.ini, /etc/php.d/mysql.ini and AFAIK the module seems to be declared. i tried to declare it once more, but then running “php -v” warns me that it’s loaded more than once. so i suppose the module is loaded.

    – just to be sure, i installed PHPMyAdmin and verified that i can see my WP table through it. i don’t know if it’s using the same module, but the fact is i can get access to mysql with it

    – at that point i supposed the problem might be that PHP 5.1 changed the mysql module name, but commenting the check in the code just leads me to a blank page.

    i’m now short of ideas, so your support will be greatly appreciated!



Viewing 1 replies (of 1 total)

    i give here mys solutions to anyone interested:

    – i forgot to restart apache (sig!) after installing the php-mysql module. shame on me!

    – after that i ran into another problem : i just misspelled the commandline in mysql to create the password and strangely MySQL didn’t complain. i didi it again w/ PHPMyAdmin, and it worked.

    BTW, stock MySQL tables (the myisam type) living in /var/lib/mysql/wordpress_db_name can be rudely copied from one DB to another. i.e. you don’t have to make a SQL dump, “cp -r” makes it.

    <shouts> Big up to the folks at – your piece of code rocks! </shouts>

Viewing 1 replies (of 1 total)
  • The topic ‘installation problem on fedora core 5’ is closed to new replies.