[resolved] Installation Problem - Blank/White Screen (12 posts)

  1. bob211
    Posted 2 years ago #

    I am getting the 'White Screen of Death' when I try to install wordpress.

    After reading the troubleshooting hints at

    I tried all of the following:
    removed all files from plugins folder,
    removed themes from themes folder,
    increased PHP memory to 64MB ( in both php.ini and wp-config.php )

    define('WP_DEBUG', true);
    define('WP_MEMORY_LIMIT', '64M');

    The php-error.log file had no messages.

    In wp-config.php I verified that all the DB info was correct.
    When I put in wrong values, I did get an error message so I know PHP is working.

    PHP version is PHP 5.3.17
    Wordpress version is 3.5.2
    Server is Apache/2.2.22 (Unix)

    I even tried installing an older version of wordpress but that failed too.

    I don't know what else to try next.
    Please help.

  2. bob211
    Posted 2 years ago #

    I was able to get the blog homepage to come up after installing wordpress on another host, then copying the database. However, all the wp-admin pages still come up blank,
    and there are no errors in either the php error log or the httpd error log.

    What is setting DEBUG to 'true' supposed to do?
    I also tried adding some 'echo' statements in the install.php file, but I got no output after the initial require_once statements.

  3. bob211
    Posted 2 years ago #

    If it helps, I determined so far that the PHP execution is not getting past the following line in wp-admin/admin.php:

    require_once(dirname(dirname(__FILE__)) . '/wp-load.php');

    The wp-load.php file is getting executed successfully from the wordpress top-level index.php page, but not from wp-admin/index.php

  4. esmi
    Forum Moderator
    Posted 2 years ago #

    Try checking your site's error logs for messages. Your hosts should be able to help you in accessing your site's error logs.

  5. Tara
    Volunteer Moderator
    Posted 2 years ago #

    What is setting DEBUG to 'true' supposed to do?

    The WP_DEBUG option, added in WordPress Version 2.3.1, controls the display of some errors and warnings. If this setting is absent from wp-config.php, then the value is assumed to be false.

    Codex: http://codex.wordpress.org/Editing_wp-config.php#Debug

  6. esmi
    Forum Moderator
    Posted 2 years ago #

    If the issue is happening very early in the lading, it may not get to WP debug. That's why the server's error log would be a better place to look.

  7. bob211
    Posted 2 years ago #

    Other than the php error log file and the httpd error log file,
    what other server log files might have information to help troubleshoot this problem?

  8. bob211
    Posted 2 years ago #

    I was able to get some error logging working by creating a page with the following code:

    error_reporting (E_ALL);include('index.php');

    Now, I see this message from admin.php

    Warning: require_once(): open_basedir restriction in effect. File([WORDPRESS_DIR]/wp-load.php) is not within the allowed path(s): (.) in [WORDPRESS_DIR]/wp-admin/admin.php on line 31 Warning: require_once([WORDPRESS_DIR]/wp-load.php): failed to open stream: Operation not permitted in [WORDPRESS_DIR]/wp-admin/admin.php on line 31 Fatal error: require_once(): Failed opening required '[WORDPRESS_DIR]/wp-load.php' (include_path='.:/usr/share/pear:/usr/share/php') in [WORDPRESS_DIR]/wp-admin/admin.php on line 31

    Any ideas?

  9. esmi
    Forum Moderator
    Posted 2 years ago #

    Sounds like a server configuration issue.

  10. sodabrain
    Posted 2 years ago #

    I suggest deleting everything and starting again.

  11. esmi
    Forum Moderator
    Posted 2 years ago #

    How is that going to deal with a server open_basedir restriction?

  12. bob211
    Posted 2 years ago #

    It turns out that it was a server configuration issue, but I got a workaround fix from the hosting provider here:


    I edited the Apache secure.conf, commented out the php module lines, and now everything works great!

Topic Closed

This topic has been closed to new replies.

About this Topic