WordPress.org

Support

Support » Installation » Installation problem

Installation problem

  • I’ve read several posts here in an attempt to figure out on my own why I’m having trouble installing WP. Sorry for sounding like a broken record, but I just can’t figure out why this isn’t working.

    The error message I’m getting is the usual “Error establishing a database connection!” etc.

    Here’s what my wp-config.php shows:

    define(‘DB_NAME’, ‘galen5_wordpress’); // The name of the database
    define(‘DB_USER’, ‘galen5_blogger’); // Your MySQL username
    define(‘DB_PASSWORD’, ‘<snip>’); // …and password
    define(‘DB_HOST’, ‘familywebwatch.com’); // 99% chance you won’t need to change this value

    I’ve created a database, created and added a user, made sure the user has all the privileges available, tried changing the host name from “localhost” to “familywebwtach.com” and “familywebwatch” and “www.familywebwatch.com”….and still getting the same error.

    I even tried asking my host if there’s anything wrong with my account that would make my database service (mysql) not function properly. They weren’t very helpful, and sent me on to someone who would do a more thorough search. But I want it NOW! 🙂

    Any help is very much appreciated.

Viewing 15 replies - 1 through 15 (of 16 total)
  • Moderator James Huff

    @macmanx

    Is this a fresh install, or has WP been working for a while? What version of WP?

    Thanks for the prompt response!

    Yes, it was a fresh install. WordPress 1.2.2, webhosting Linux Red Hat 7.3 with Apache.

    Moderator James Huff

    @macmanx

    Try a full URL, http:// and all for DB_HOST.

    Just tried it and same error message. Even tried it both ways, “http://www…….com” and “http://www…..com/blog”.

    This is really getting frustrating. I’ve heard so many good things about WordPress that I want it to work. The answer’s gotta be somewhere.

    Oh and just to be sure I’ve made it clear, I uploaded all the files in the wordpress folder to a folder on my server called “blog” which is located at http://www.familywebwatch.com/blog. Is that all right?

    Moderator James Huff

    @macmanx

    You’re files are in the right place, but from what you’re telling me (trying /blog in DB_HOST), you don’t know where your database host is. Your database host (DB_HOST) is where your MySQL database is hosted. Your web host’s user interface should provide that information.

    Sorry, kind of new at this. Okay, so I located the location of the host in the cpanel. Tried that, got the error. Tried adding the port number to the end of the location and got the same error. Also tried using the IP address…still nothing.

    Sorry for the trouble. I’m really not new to the web, just new to some of this stuff. Any further help you can offer is very much appreciated!

    Moderator James Huff

    @macmanx

    Ah, cPanel! That clears up a few things. Read this (a WordPress installation guide for cPanel):
    http://www.tamba2.org.uk/wordpress/cpanel/

    Hmmm, maybe I mispoke. I was using cPanel as shorthand for control panel, but it seems that you might be referring to a type of interface that has been branded “cPanel”? I don’t know if that makes a difference, but the link you suggested provided examples that didn’t look like what I see in my control panel (here’s a sample interface: http://www.websitesource.com/clientarea/control-panel.shtml ; I don’t use this particular skin, but I figure it’s just an interface providing access to the same stuff).

    Anyway, the sample refers to a “connection string” which seems to be the important thing that would verify the location of the db. I can’t find that information in my control panel…perhaps I’m looking in the wrong place.

    If I understand this correctly, I’m thinking that one thing you have NOT done is try “localhost.” Is that correct? I’ve re-read this thread a couple of times, and it appears that you changed “localhost” right away from the beginning. If so, then try it with “localhost.”

    Otherwise, if I have misunderstood you, then just ignore me! Thousands do! :0)

    I wish it was that easy and maybe it is, but it may be something else because I left it at localhost at the start.

    After a few other tries I changed it. Most recently (like right now, in fact), I changed it back to the specific host name that shows up in my control panel. Same thing happened: “error connecting…”.

    Oh and btw, in case this helps, I found that I’m using phpMyAdmin.

    I really appreciate everyone’s help. Please don’t give up on me. I feel that we’re SO close to figuring this thing out!!

    Okay, did some more digging: the help file (http://codex.wordpress.org/Installation#Using_phpMyAdmin) says:

    “1. If a database relating to WordPress does not already exist in the Database dropdown on the left, create one:”

    One does exist. It goes on to say:

    “2. Click the Home icon in the upper left to return to the main page, then click Privileges. If a user relating to WordPress does not already exist in the list of users, create one:”

    Well, “Privileges” can’t be found anywhere! All I have in the right pane when I click on “Home” is: “Create New Databases” (which doesn’t let me create one, btw), “Show processes”, “databases”, etc.

    Now when I click on “Show Processes” I get something interesting. It gives me a table with several column headers, one of which says “Database” with the word “None” below it. What’s up with that? I’m in the database so why is it showing that it doesn’t exist.

    Again, thanks in advance for hanging with me. I’m going to be really ticked if this is because of my host.

    anybody have any more ideas?

    At this point I would suggest continuing to hound your host.

    Yeah, that was my guess, too. In fact, I emailed them earlier to see if they could get involved. Was hoping someone else here might have had the same experience and shed some light. I’ll keep plugging away at it.

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Installation problem’ is closed to new replies.
Skip to toolbar