• Resolved hommealone

    (@hommealone)


    Hi, when I try to install and activate the plugin using the standard “Add New” plugin method, I get the following notice:

    The plugin generated 226 characters of unexpected output during activation. If you notice “headers already sent” messages, problems with syndication feeds or other issues, try deactivating or removing this plugin.

    Once I then try to add a set of keys, I get fatal errors like those described in the activation notice.

    I’ve tried twice (deleting the plugin after the first try, and trying again) and get the same result both times.

    Any idea what’s wrong, or how I should proceed? I use this excellent plugin on many sites and want to install it on this new site but can’t.

    • This topic was modified 6 months, 1 week ago by hommealone.
Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author Shamim Hasan

    (@shamim51)

    What is your php version?
    Can you please see your server error log if there any error about this?
    Also a new version is released couple of minutes ago, So there might be caching issue with wordpress, Can you try one more time?

    I have tried in multiple websites after this release and everything seems working good.

    Let me know.

    Thread Starter hommealone

    (@hommealone)

    Thanks for your quick reply! I just tried again and got the same activation notice.

    We are running PHP Version 7.4

    I’ll try to check the log and see if there is anything listed.

    Thread Starter hommealone

    (@hommealone)

    I Deleted the plugin again. Then I set:

    define( 'WP_DEBUG_LOG', true );

    Then I re-installed the plugin and re-activated. No entry in debug.log (in fact, no debug.log file generated yet; no errors.

    When I visited the settings page after re-installation (and our keys were still there; I assume they are stored in the WP database) and re-saved the settings, I got a white screen with these error messages:

    Notice: Undefined index: type in /home/ourserverusername/public_html/wp-content/plugins/advanced-nocaptcha-recaptcha/admin/settings.php on line 425
    
    Notice: Undefined index: type in /home/ourserverusername/public_html/wp-content/plugins/advanced-nocaptcha-recaptcha/admin/settings.php on line 458
    
    Notice: Undefined index: type in /home/ourserverusername/public_html/wp-content/plugins/advanced-nocaptcha-recaptcha/admin/settings.php on line 425
    
    Notice: Undefined index: type in /home/ourserverusername/public_html/wp-content/plugins/advanced-nocaptcha-recaptcha/admin/settings.php on line 458
    
    Notice: Undefined index: type in /home/ourserverusername/public_html/wp-content/plugins/advanced-nocaptcha-recaptcha/admin/settings.php on line 425
    
    Notice: Undefined index: type in /home/ourserverusername/public_html/wp-content/plugins/advanced-nocaptcha-recaptcha/admin/settings.php on line 458
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/ourserverusername/public_html/wp-content/plugins/advanced-nocaptcha-recaptcha/admin/settings.php:425) in /home/ourserverusername/public_html/wp-includes/pluggable.php on line 1296
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/ourserverusername/public_html/wp-content/plugins/advanced-nocaptcha-recaptcha/admin/settings.php:425) in /home/ourserverusername/public_html/wp-includes/pluggable.php on line 1299
    
    Plugin Author Shamim Hasan

    (@shamim51)

    Thank you for the error log.
    i have made some changes. Can you download and install from https://github.com/shamim2883/advanced-nocaptcha-recaptcha and test?
    Let me know. If everything alright i will push update in wordpress with this changes.

    Thread Starter hommealone

    (@hommealone)

    OK. Here’s what I did:

    I again deleted the plugin.

    I installed the version that I got from GitHub.

    When I activated that version, I still got this activation notice:

    The plugin generated 233 characters of unexpected output during activation. If you notice “headers already sent” messages, problems with syndication feeds or other issues, try deactivating or removing this plugin.

    I went to the plugin’s settings page, and re-saved the settings.

    This time when I went to the settings page of the plugin and re-saved the settings, I got no error messages.

    (And the plugin seems to be working; reCaptcha elements are in place.)

    So, now it seems to be just the activation warning that’s a problem.

    Plugin Author Shamim Hasan

    (@shamim51)

    Thank you.
    Can you please see your server error log if there any error logged during activation? You can get help from your host to locate server error log if you do not know where that is.

    Let me know.

    Thread Starter hommealone

    (@hommealone)

    Might be a plugin conflict with WP Zero Spam?

    I uninstalled and re-installed from the WP repository.

    Upon activation:

    The plugin generated 226 characters of unexpected output during activation. If you notice “headers already sent” messages, problems with syndication feeds or other issues, try deactivating or removing this plugin.

    Server error log:

    [13-Oct-2020 18:54:58 UTC] PHP Warning:  Cannot modify header information - headers already sent in /home/ourserverusername/public_html/wp-content/plugins/zero-spam/classes/class-wpzerospam.php on line 938
    [13-Oct-2020 18:56:08 UTC] PHP Notice:  Trying to access array offset on value of type null in /home/ourserverusername/public_html/wp-content/plugins/advanced-nocaptcha-recaptcha/freemius/includes/class-freemius.php on line 7767
    
    • This reply was modified 6 months, 1 week ago by hommealone.
    Thread Starter hommealone

    (@hommealone)

    When re-installed from the repository, I also got the fatal errors.

    When I again deleted and re-installed Github version, got activation error but saving the plugin settings succeeded without fatal errors.

    Additional log errors from these two additional delete-and-re-install attempts:

    [13-Oct-2020 19:12:02 UTC] PHP Warning: Cannot modify header information – headers already sent by (output started at /home/serverusername/public_html/wp-content/plugins/advanced-nocaptcha-recaptcha/admin/settings.php:425) in /home/serverusername/public_html/wp-includes/pluggable.php on line 1296
    [13-Oct-2020 19:12:02 UTC] PHP Warning: Cannot modify header information – headers already sent by (output started at /home/serverusername/public_html/wp-content/plugins/advanced-nocaptcha-recaptcha/admin/settings.php:425) in /home/serverusername/public_html/wp-includes/pluggable.php on line 1299

    [13-Oct-2020 19:13:40 UTC] PHP Notice: Trying to access array offset on value of type null in /home/serverusername/public_html/wp-content/plugins/advanced-nocaptcha-recaptcha-master/freemius/includes/class-freemius.php on line 7767

    Plugin Author Shamim Hasan

    (@shamim51)

    Thank you very much.
    This is not a conflict with that plugin but with PHP version 7.4
    We will fix it and push an update.

    Thread Starter hommealone

    (@hommealone)

    Great news, thank you. I appreciate how much work it takes to maintain your excellent plugin. Thank you for making it available. I hope I was able to be helpful in some small way.

    Keep up the good work!

    Thread Starter hommealone

    (@hommealone)

    Oh! Just one other very minor suggestion:

    In my themes, I always add a bottom margin to the “I am not a robot”-type reCaptcha element so that it doesn’t bang up against the submit button. That works in comment forms and CF7, but not in login, forgot password and etc. Since you have some basic default styling of those screens for the reCaptcha element, I’d suggest that you add a small bottom margin there, so it doesn’t bump against the submit button on those screens. (rem units work well.)

    Plugin Author Shamim Hasan

    (@shamim51)

    I normally suggest to add .anr_captcha_field_div {clear: both;} (if require some margin) in additional CSS. As there is settings to remove this plugin’s css. Also this plugin css does not load always, it just load in default wp login form.

    Plugin Author Shamim Hasan

    (@shamim51)

    @hommealone i have pushed a new version with this fix. Can you please check and let me know?

    Thread Starter hommealone

    (@hommealone)

    @shamim51
    All good! I deleted the plugin, then re-installed from the WP repository:

    No activation errors.
    No log file error.
    It is working as expected.

    Thanks so much! Your attention to this issue is greatly appreciated and noted!

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Installation Problem’ is closed to new replies.