• Resolved robzarryjr

    (@robzarryjr)


    Hello!

    I installed PDF 2 post, guessing I did something wrong as I get this error when I try to use the New Post From PDF function:

    File upload successful! attachementy ID : 5CANNOT OPEN zip here: unknown error

    Is there a log file I can look at to help troubleshoot?

    Thanks!

    Rob

Viewing 7 replies - 16 through 22 (of 22 total)
  • Plugin Author termel

    (@munger41)

    Big changes made to code, can you please re-test with version 2.0+ ?
    You need to upload a single PDF file or a zip containing a folder with multiple pdf file inside. You need to have this root folder in your zip.

    Thread Starter robzarryjr

    (@robzarryjr)

    Apologies for the late reply, went out for a while!

    Tried the upgrade the plugin, ran into a permissions issue, probably on my side as it was a manual install starting with a blank Ubuntu image & building the LAMP stack then installing wordpress.

    Once version two was installed I see the following:

    1) When first clicking New Post from PDF, this message appears at the top left corner:

    The security check failed

    2) I ignored that & uploaded a single PDF (the one that was in the zip file I sent earlier today) & got the following:

    File upload successful! /var/www/html/wp-content/uploads/2018/02/Meals-for-Montana-Funding-1-3.pdf
    Go to new post : Meals-for-Montana-Funding-1-3

    3) New post is created and accessible via the Go to new post link above. There are two issues with the conversion:

    3.1) Images are not correctly substituted / sized
    3.2) Text formatting is not correct.

    I published the page to: http://159.65.232.72/2018/02/26/meals-for-montana-funding-1-3/ so you can compare the original PDF with the generated page.

    I figured it would be better to stop here & check / fix before moving on to the ZIP file test…

    Please let me know if you have questions.

    Thanks!!!

    Rob

    Plugin Author termel

    (@munger41)

    For 1, yes you can ignore it
    2) seems it worked then
    3.1 and 3.2 ) pdp2post is not design to recreate exact layout of original pdf, rather to quickly create a simple post, but we could investigate it if you wish.
    Thanks for your tests

    Thread Starter robzarryjr

    (@robzarryjr)

    Great feedback, thanks!

    Only thing would like to have investigated is the fact that the images did not get inserted correctly. The one at the top of the original PDF is missing from both the post and the media library and the footer contains two copies of one image and is missing the third from the right image from the original pdf.

    Does this explanation make sense?

    If not, I can make two printouts, scan them and attach to the contact form you previously sent the link to.

    Thanks for all your help!

    Rob

    I see what you mean, let us investigate a bit more then, even if this may be linked to pdfimages library and thus out of our control.

    Plugin Author termel

    (@munger41)

    Pdfimages seem to output only those images, we’ll check for a possible command setting

    Plugin Author termel

    (@munger41)

    This is a pdfimages limitation, i am sorry.

Viewing 7 replies - 16 through 22 (of 22 total)
  • The topic ‘Installation problem?’ is closed to new replies.