WordPress.org

Support

Support » Installation » Installation of WP in subdomain not working

Installation of WP in subdomain not working

Viewing 10 replies - 1 through 10 (of 10 total)
  • esmi
    Forum Moderator

    @esmi

    Firefox can’t find the server at blog.emerald-planet.org.

    NeedWPSupport
    Member

    @needwpsupport

    Firefox can’t find the server at blog.emerald-planet.org.

    Yes that is the link for the live subdomain, but it is not live yet so it is broken, I did try to redirect to a temp URL but it does not WORK!!! I am not sure if something is wrong with the wp-config.php file or something else that is forcing the URL to the live URL instead of the temp URL.

    esmi
    Forum Moderator

    @esmi

    You cannot install WordPress on a sub-domain until that sub-domain is live.

    NeedWPSupport
    Member

    @needwpsupport

    Will I have to make the whole domain live? I guess a better question would be that is there a way to make the subdomain live without making the whole domain live?

    esmi
    Forum Moderator

    @esmi

    I very much doubt it but your hosts are the best people to ask about this.

    Asif Mushtaq
    Member

    @asifmushtaq38

    Firefox can’t find the server at blog.emerald-planet.org.

    its not wordpress installation problem this your hosting problem… delete complete wordpress from your subdomain and add index.html file with something, if then your sub domain running fine then may its wordpress problem.. if not then contact your hosting provider…

    open your database and change the domain name in the firsts row of the wp_options column to your current address . ie address with subdomain which is something like this
    <sub.domain.com>
    I have done the same with business.sukhim.com and guess what it worked well.

    NeedWPSupport
    Member

    @needwpsupport

    Hello everyone, thanks for all your help! I have figured out the problem and found a solution for it. I am updating this post to help anyone in the future that may come across the same problem.

    After fiddling around with the database for both domain and subdomain as well as trying to manage redirections which all failed; I looked at the wp-config.php file for the subdomain and compared it to the wp-config.php file for the original domain. Remember:

    http://198.46.82.35/~emeral53/content <—Original WP installation
    http://198.46.82.35/~emeral53/Blog <—Subdomain WP installation

    In the subdomain config file the problem was a code block which had the multisite functionalities enabled. I highlighted that whole code part and deleted it. After saving the file and going back to the

    URL: http://198.46.82.35/~emeral53/Blog

    IT WORKED! I hope this clarified everything, and thanks for your help!

    thankyouguys
    Member

    @thankyouguys

    hello,

    How is your sites working?

    I went into my subdomain ‘wp-config.php’ file and wondered which part to delete.

    Can you be kind enough to tell me which specific part?

    Thank you.

    esmi
    Forum Moderator

    @esmi

    @thankyouguys: If you require assistance then, as per the Forum Welcome, please post your own topic.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Installation of WP in subdomain not working’ is closed to new replies.