Support » Installing WordPress » Installation Notice: Undefined index: SCRIPT_FILENAME in wp-settings?

  • Trying to install WP 2.0 using the install.php script even for databas creation.

    Can’t even create the WP database (have done it before!)… the install script ends after checking that it can communicate with my DB (http://my_secret/setup-config.php?step=2).

    I get the following message:

    Notice: Undefined index: SCRIPT_FILENAME in \\my_secret_path\wp-settings.php on line 38

    Notice: Undefined index: SCRIPT_FILENAME in \\my_secret_path\wp-settings.php on line 38

    Parse error: parse error, unexpected $end in \\my_secret_path\wp-includes\functions-compat.php on line 71

    Seams like this checkup in the wp-settings.php file is new?

    Please can anyone help?

Viewing 7 replies - 1 through 7 (of 7 total)
  • using the install.php script even for databas creation

    Hmmm. WP does NOT create the database – only the tables it needs in an existing databse.

    …sorry… the tables are not created in my current DB (I check with MySQLAdmin) that my host holds for me (which it does in previous WP versions).

    I get the errormessage when script moves from setup-config.php?step=2 to install.php…

    Line 38 in wp-settings.php is a “fix” for (quote):
    // Fix for PHP as CGI hosts that set SCRIPT_FILENAME to something ending in php.cgi for all requests

    Is this the case with your server?

    Actually I have no idea… and I don’t really know the meaning of that comment… (*sorry*)

    If I just take away that portion of code(?) I stil end up with the Parse error: parse error, unexpected $end in \\my_secret_path\wp-includes\functions-compat.php on line 71

    But really, don’t know if I should do that… 😉

    STOP HELP ME… it’s seams lika I have some corrupt files from my upload!

    I’ll check that out!

    YES FINALLY!

    For some reason one of my files was corrupt!
    Fixing that I still had the //Fix for PHP problem… so I just took that portion of code away and now… it seams to work!

    Great, lets start bloging! 🙂

    Glad it worked out for you. Happy blogging 🙂

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Installation Notice: Undefined index: SCRIPT_FILENAME in wp-settings?’ is closed to new replies.