WordPress.org

Forums

[resolved] Installation / Moving gone wrong (20 posts)

  1. akizuri
    Member
    Posted 1 year ago #

    Hi.

    I have an old html website I wanted to update to WordPress. I installed WordPress in a sub folder called "WordPress" and developed my new site. Now I wanted to move the WordPress site to the main adress (it was http://www.akizuri.dk/wordpress - and I wanted it to be found on http://www.akizuri.dk and I wanted my old site to be retired.
    I changed the link in settings in the WordPress admin - and then everything went wrong.... Trying to fix it by overwriting all the documents with the backup I made some days ago (a complete copy of all files). But still it dosent Work!
    Can anyone help???? (and please note that I am a novice at this, so please explain in simple Words :)

  2. SKTThemes
    Member
    Posted 1 year ago #

    Hi,

    Its simple you changed the links from link settings but this is not right method.

    Do one thing zip the old html as oldsite.zip and move the contents of wordpress folder to root.

    Please then check if the site starts working again or not.

    Here are some links which might help:

    http://codex.wordpress.org/Moving_WordPress

  3. Laxman92
    Member
    Posted 1 year ago #

    Hello,

    Step 1 :
    Database in wp-option table in change siteurl
    http://www.akizuri.dk/wordpress
    to
    http://www.akizuri.dk

    Step : 2
    Database in wp-option table in change home
    http://www.akizuri.dk/wordpress
    to
    http://www.akizuri.dk

    Step : 3
    Check /project/wp-config.php file in databasename, username and password.

    Apply this step and check again.

  4. akizuri
    Member
    Posted 1 year ago #

    Hello,

    Thanks for your answer - but you already lost me in step 1!!!

  5. Laxman92
    Member
    Posted 1 year ago #

    Your problem is solved ?
    Not solved than what's a problem ?

    Posible than i help to you...

  6. akizuri
    Member
    Posted 1 year ago #

    No - the problem isn't solved. Take a look at http://www.akizuri.dk/wordpress

    Thank you for your help, but I don't understand: "Database in wp-option table in change siteurl"???

  7. esmi
    Forum Moderator
    Posted 1 year ago #

    Change the urls back. See Changing_The_Site_URL for details of how to do this correctly.

  8. akizuri
    Member
    Posted 1 year ago #

    But I can't even log in? So how can I change the urls back?

  9. esmi
    Forum Moderator
    Posted 1 year ago #

    Now try reading the page at the link I posted above. None of the suggestions made require you to login to your WordPress dashboard.

  10. Laxman92
    Member
    Posted 1 year ago #

    Write now your wordpress is http://www.akizuri.dk/wordpress .

    and u upload in http://www.akizuri.dk .

    than change url in your wordpress database in wp_option tabal ( see my previous post)

  11. christinaj
    Member
    Posted 1 year ago #

    SKTThemes provide best solution ....

    [Link moderated]

  12. akizuri
    Member
    Posted 1 year ago #

    Okay.... I fixed the http://www.akizuri.dk/wordpress

    But I still can't move the site :(
    1. I tried to change the settings via phpMYadmin.
    2. I tried to change the settings in the WordPress admin under settings/general and move the WordPress installation to the site root (after deleting all existing files in the root folder)

    Right now both sites are working Again - but what to do?

  13. esmi
    Forum Moderator
    Posted 1 year ago #

    If you are quite sure that the site is now back in it's original state and is working correctly, see Allow WordPress to take over the root domain.

  14. akizuri
    Member
    Posted 1 year ago #

    I don't have an .htaccess file in my WordPress folder - even if I choose "show hidden files". Is that perhaps the problem?

  15. esmi
    Forum Moderator
    Posted 1 year ago #

    No. If you were not using custom permalinks, you may not have an .htaccess file.

  16. Handsdown421
    Member
    Posted 1 year ago #

    If you want to move the site, I found this tool helpful for changing everything in your database to the new URL: http://interconnectit.com/products/search-and-replace-for-wordpress-databases/

    1. Go into wordpress settings at http://www.akizuri.dk/wordpress and change URL to http://www.akizuri.dk

    2. Use ftp to move http://www.akizuri.dk/wordpress files to http://www.akizuri.dk

    3.Use tool above to search for
    http://www.akizuri.dk/wordpress

    Replace with
    http://www.akizuri.dk

    Hope this helps

  17. Handsdown421
    Member
    Posted 1 year ago #

    If you do not have an .htaccess folder you can create a new one.

  18. esmi
    Forum Moderator
    Posted 1 year ago #

    .htaccess folder?

  19. Handsdown421
    Member
    Posted 1 year ago #

    It's just a file in the root directory

    Create an empty text document, then rename the file.

    If you're using Windows, you won't be able to rename the file to .htaccess , to get around this just uploaded the file as is "any name", then rename it once it's on the server.

  20. akizuri
    Member
    Posted 1 year ago #

    I solved it! Just kept the .htaccess already in the root folder and it worked :)

    Thank you all for your help!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.