WordPress.org

Support

Support » Installation » Installation help please

Installation help please

  • I tried install WordPress on local computer. I all way got the message: “Error establishing a database connection”, but I can use the same username and password connect to MySQL through DOS command. On the wp-config.php, my script is:
    <?php
    // ** MySQL settings ** //

    define(‘DB_NAME’,’wordpress’); // The name of the database
    define(‘DB_USER’,’wpadmin’); // Your MySQL username
    define(‘DB_PASSWORD’,’*******’); // …and password
    define(‘DB_HOST’,’localhost’); // 99% chance you won’t need to change this value

    // Change the prefix if you want to have multiple blogs in a single database.
    $table_prefix = ‘wp_’; // example: ‘wp_’ or ‘b2’ or ‘mylogin_’

    // Change this to localize WordPress. A corresponding MO file for the
    // chosen language must be installed to wp-includes/languages.
    // For example, install de.mo to wp-includes/languages and set WPLANG to ‘de’
    // to enable German language support.
    define (‘WPLANG’, ”);

    /* Stop editing */

    define(‘ABSPATH’, dirname(__FILE__).’/’);
    require_once(ABSPATH.’wp-settings.php’);

    ?>

    I read a lot of review and advice in this site and it seem doesn’t work for me. Please help me.
    Thank you in advance.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Mark (podz)

    @podz

    Support Maven

    “but I can use the same username and password connect to MySQL through DOS command.”

    please tell us what the full local setup is ?

    I installed:
    mysql 4.1.11
    apache 2.0.54
    php 4.3.11
    I run all above program on windows 2000.

    After I installed those, I went to dos command and run this mysql -h localhost -u wpadmin -p It let me logon and view the database.

    I don’t know what else you need to know. Please let me know if you would like more information about it.

    Thanks.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Installation help please’ is closed to new replies.