WordPress.org

Support

Support » Installation » Installation help needed

Installation help needed

Viewing 15 replies - 16 through 30 (of 74 total)
  • ok so how did you get to wp-config-sample.php in notepad. I went to notepad and I get wordpress with gibberish but I dont get any place to choose the sample php file.
    I really appreciate this help. Please hang in there with me.

    I opened the zip file and then I clicked on the sample php and the stuff I need to change is there you know the database info and in that window on the top it say notepad without me having to go to notepad. Do you think I should make the changes there?

    So you’re saying that you’ve already tried to open the files in Notepad but they just come out as gibberish? That sounds like there’s something wrong with the files you downloaded. Did you unzip and decompress the files after you downloaded them? Right now, that sounds like the most likely explanation.

    Try opening it in WordPad instead. Go to the file and right click on it, choose open with , then choose either notepad or wordpad to open it. Then you can edit it. I use EditPlus myself to edit php pages so im not sure which will work for you WordPad or NotePad, since you said Notepad made it gibberish

    I went to the folder where I have the wordpress zip file. I clicked on the I AGREE part then a window opens up with all these files that pertain to wordpress. I scrolled down until I came to wp-config-sample.php and when I opened that one line came out that I assume is where I should make the corrections like LOCAL HOST and so forth. However, my question is, should I make those changes there and then save it with a new name?

    <?php
    // ** MySQL settings ** //
    define(‘DB_NAME’, ‘wordpress’); // The name of the database
    define(‘DB_USER’, ‘username’); // Your MySQL username
    define(‘DB_PASSWORD’, ‘password’); // …and password
    define(‘DB_HOST’, ‘localhost’); // 99% chance you won’t need to change this value

    // Change the prefix if you want to have multiple blogs in a single database.
    $table_prefix = ‘wp_’; // example: ‘wp_’ or ‘b2’ or ‘mylogin_’

    // Change this to localize WordPress. A corresponding MO file for the
    // chosen language must be installed to wp-includes/languages.
    // For example, install de.mo to wp-includes/languages and set WPLANG to ‘de’
    // to enable German language support.
    define (‘WPLANG’, ”);

    /* Stop editing */

    define(‘ABSPATH’, dirname(__FILE__).’/’);
    require_once(ABSPATH.’wp-settings.php’);
    ?>

    that is what shows up in the sample window when I click it without going to notepad however in that window on the top it says notepad. even this will be difficult to fill in. so should i make the changes in this window?

    That’s exactly what you’re supposed to be seeing. This is the place where you should be making your changes.

    ok so based on what I pasted above to you what do I delete or replace. I am scared since I know that one wrong move can mess me up.

    define('DB_NAME', 'wordpress'); // The name of the database
    define('DB_USER', 'username'); // Your MySQL username
    define('DB_PASSWORD', 'password'); // ...and password

    Replace the stuff in ‘single quotes’ with your information, keeping the ‘single quotes’ around. The database name goes in the first line, the MySQL username goes in the second line, and the password goes in the third line, just like the instructions say. ^_^

    pretend for the sake of arguement, that the DB is peanuts_wordpress because when it asked for db I typed Peanuts but when i see it on the screen it added the underscore and the word wordpress. Do I type peanuts inbetween the single quotes or do i type peanuts_wordpress. By the way this happened to all of the other stuff.

    That’s just becasue cPanel likes to do that. You should use the names with the peanuts_ prefix. It did to that for my MySQL stuff too. Use the prefix.

    should I put an underscore and prefix for the password as well? and when I do that do I go to file in that window and save it under the file name sample or do I change the name? UGH> PLEASE HANG IN THERE>

    Don’t use the prefix for the password. cPanel only adds the prefix to database and usernames.

    After you’re done editing the wp-config-sample.php, go to File>Save As and then enter wp-config.php in the “File Name” field. Then click OK. This way, if you messed something up, the old wp-config-sample.php will always be around for you to go back to and still have all the original settings.

    To answer your query:

    If your db is named peanuts – and your username is diamondgirl
    then you would use the following:

    define('DB_NAME', 'diamondgirl_peanuts'); // The name of the database

    The username part would be the username for the database. So if you made a database which uses the username of balls it would be as follows:

    define('DB_USER', 'diamondgirl_balls'); // Your MySQL username

    your password, if it was goats would be as follows:

    define('DB_PASSWORD', 'goats'); // ...and password

    Leave this section alone:

    define('DB_HOST', 'localhost'); // 99% chance you won't need to change this value

    All your questions are answered in all the links provided here, from setting up the db to getting it working. It’s in your itnerest to read and follow them

    Save this file as wp-config.php.

Viewing 15 replies - 16 through 30 (of 74 total)
  • The topic ‘Installation help needed’ is closed to new replies.