Support » Plugin: NinjaFirewall (WP Edition) - Advanced Security Plugin and Firewall » Installation hangs on system configuration

  • Resolved alex_pfa

    (@alex_pfa)


    I had Ninja Firewall on a site for a while now. Today I got an error in the Ninja Dashboard. After some tries of solving the error I uninstalled Ninja Firewall and reinstalled it.
    Now I’m hang at the second step of the installation where I can select .user.ini. Every time I select and click “next” stays on the page and my selection is gone.
    No error message appears.
    I run also the check script. There all seems to be ok.
    No idea whats going wrong. Hopefully someone can help me.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author nintechnet

    (@nintechnet)

    Do you remember what was the error message in the dashboard before you uninstalled it? Was is related to a PHP session issue and not being whitelisted?

    Thread Starter alex_pfa

    (@alex_pfa)

    Yes it was in the ninja dashboard at “admin user” and said that the user is maybe not whitelisted.
    Before I tried to install a plugin which was blocked.

    Plugin Author nintechnet

    (@nintechnet)

    That’s a PHP session issue. You may have a plugin that either messes with PHP session (starting a session without checking if one has already been started), or simply has a bug/error/notice that throws a PHP error message forcing the HTTP headers to be sent to early (hence preventing the session to be created). The PHP error message may not be visible to you, but could be viewed by enabling the WP_DEBUG constant in your wp-config.php or by checking your PHP error log(s).
    If you installed a plugin or them lately, it may be the culprit.

    Thread Starter alex_pfa

    (@alex_pfa)

    Thanks, you were right. I deactivated all plugins and it worked.
    Now, when I enabled all of them again it still works – strange.
    But anyway, now I know that is a issue with one of the plugins and I will manage to find it.

    thanks a lot

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Installation hangs on system configuration’ is closed to new replies.