Support » Plugin: YOP Poll » Installation for new language translation does’nt work

  • Hello all the Yop Poll team
    ———-
    Yop Poll installed version: 6.0.1
    Wordpress installed version : WordPress 4.9.8–fr_FR
    ———-

    I’ve download the French translation file with the name: wp-plugins-yop-poll-dev-fr.po at this place (Translation of Development (trunk): French)

    I’ve open this file (.po) in the last PoEdit version (2.1.1) and translated all the french missing translations, then save the file in the “.mo” extension (compressed PO) and rename it yop-poll-fr_FR.mo then uploaded the 2 files (yop-poll-fr_FR.mo and yop-poll-fr_FR.po) in the “languages” folder in the “yop-poll” plugin directory.

    Note : i’ve find the textdomain “yop-poll” in the file public.php (in folder “public”), line 66-68 :

    public function load_translation() {
    		load_plugin_textdomain( 'yop-poll', false, dirname( plugin_basename( __FILE__ ) ) . '/languages' );
    	}

    But nothing work, the French translation is missing, it is not taken into account despite the refresh of the pages.

    Can you please help me to find the cause of this dysfunction.
    Thanks a lot
    JB

    • This topic was modified 2 months, 2 weeks ago by  studiojb.
Viewing 1 replies (of 1 total)
  • Hi there

    When you export the translation file, it looks like this: wp-plugins-yop-poll-dev-fr.po

    I had to rename the file like this: yop-poll-fr_FR.po

    So in my case, the file looks like this: yop-poll-de_DE.mo and yop-poll-de_DE.po

    Regards
    Mischa

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.