• Resolved Jeremy

    (@hidohebhi)


    I tried installing the plugin on 3 different sites (and 3 different servers), but every time I try to activate, I get this error:

    Fatal error: Using $this when not in object context in …/wp-content/plugins/inline-google-spreadsheet-viewer/inline-gdocs-viewer.php on line 130

    PHP versions 5.5 – 7.1, so I don’t think it’s a deprecated PHP issue. And like I said, it was on 3 different sites, all with different servers (and different everything else as well).

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author Meitar

    (@meitar)

    Oops, this is almost certainly my bad. Let me have a look at it and see about pushing out a quick fix. Thanks for letting me know.

    Plugin Author Meitar

    (@meitar)

    Can you try installing this development version (0.12.1) and see if this works for you? Thanks again and sorry about the mess up.

    Thread Starter Jeremy

    (@hidohebhi)

    I just tried the .12.1 version and it gives me a different error:

    Fatal error: Access to undeclared static property: WP_IGSV\InlineGoogleSpreadsheetViewerPlugin::$dt_class in …/wp-content/plugins/inline-gdocs-viewer-develop/inline-gdocs-viewer.php on line 130

    I suddenly today got the excact same error.. please fix

    Glad to know it wasn’t just me 😀

    • This reply was modified 7 years, 1 month ago by HBauthor.
    Plugin Author Meitar

    (@meitar)

    Yeah, it’s not you, this one is my fault, my apologies.

    I pushed out 0.12.1 after taking a closer look. The 0.12 version contained relatively big code refactoring and it looks like I didn’t cover all my cases. 🙁

    Try updating to 0.12.1 and see if that helps resolve these issues. Thanks again for informing me of the issue so quickly!

    No worries! I was able to activate it this time, and I’ll see about trying it out tomorrow. Thanks!

    Dear Meitar, I did try 12.1 yesterday. The dev version you posted in this thread, and got following error when trying to activate:
    Fatal error: Access to undeclared static property: WP_IGSV\InlineGoogleSpreadsheetViewerPlugin::$dt_class in …/wp-content/plugins/inline-gdocs-viewer-develop/inline-gdocs-viewer.php on line 130

    Oh, I updated mine through wordpress’s update plugin feature, rather than installing it. So, whatever was offered as an update through wordpress was what I used.

    Plugin Author Meitar

    (@meitar)

    The published 0.12.1 version is not the same as the dev version linked above. Use the WordPress update mechanism to get the published and tagged release.

    it worked well with the published release, thank you very much

    Error forget this

    I tried activating the plugin and got the following error:

    Parse error: syntax error, unexpected T_STRING in /hsphere/local/home/c145777/nathan.rob-walker.com/wp/wp-content/plugins/inline-google-spreadsheet-viewer/inline-gdocs-viewer.php on line 25

    Have tried installing and activating the version when searching plug ins through wordpress and also the zip file from wordpress.org

    Plugin Author Meitar

    (@meitar)

    @nathan19867, you need to use PHP 5.3 or later. You’re using PHP 5.2 or earlier. See the changelog or the Installation notes in the readme, which both mention this change as part of the update to 0.12.x.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Installation Fatal Error’ is closed to new replies.