Support » Plugin: WP-Paginate » Installation fails in php 8

  • This is what I get:

    wp-die-message { display: none; } Fatal error: Uncaught Error: call_user_func_array(): Argument #1 ($function) must be a valid callback, array must have exactly two membersin /home/mysite/public_html/wp-includes/class-wp-hook.php on line 292Call stack:WP_Hook::apply_filters()wp-includes/class-wp-hook.php:316WP_Hook::do_action()wp-includes/plugin.php:484do_action()wp-admin/includes/class-wp-upgrader.php:857WP_Upgrader::run()wp-admin/includes/class-plugin-upgrader.php:137Plugin_Upgrader::install()wp-admin/includes/ajax-actions.php:4354wp_ajax_install_plugin()wp-includes/class-wp-hook.php:292WP_Hook::apply_filters()wp-includes/class-wp-hook.php:316WP_Hook::do_action()wp-includes/plugin.php:484do_action()wp-admin/admin-ajax.php:187Query Monitor Fatal error: Uncaught TypeError: call_user_func_array(): Argument #1 ($function) must be a valid callback, array must have exactly two members in /home/mysite/public_html/wp-includes/class-wp-hook.php:292 Stack trace: #0 /home/mysite/public_html/wp-includes/class-wp-hook.php(316): WP_Hook->apply_filters(NULL, Array) #1 /home/mysite/public_html/wp-includes/plugin.php(484): WP_Hook->do_action(Array) #2 /home/mysite/public_html/wp-admin/includes/class-wp-upgrader.php(857): do_action('upgrader_proces...', Object(Plugin_Upgrader), Array) #3 /home/mysite/public_html/wp-admin/includes/class-plugin-upgrader.php(137): WP_Upgrader->run(Array) #4 /home/mysite/public_html/wp-admin/includes/ajax-actions.php(4354): Plugin_Upgrader->install('https://downloa...') #5 /home/mysite/public_html/wp-includes/class-wp-hook.php(292): wp_ajax_install_plugin('') #6 /home/mysite/public_html/wp-includes/class-wp-hook.php(316): WP_Hook->apply_filters('', Array) #7 /home/mysite/public_html/wp-includes/plugin.php(484): WP_Hook->do_action(Array) #8 /home/mysite/public_html/wp-admin/admin-ajax.php(187): do_action('wp_ajax_install...') #9 {main} thrown in /home/mysite/public_html/wp-includes/class-wp-hook.php on line 292

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author AlanP57

    (@alanp57)

    I just tested a fresh install on a site using PHP 8 with no issues. Can you send us information about your site configuration? Go to the Media Library Folders Support page on your site, to the System Information tab. There, highlight and copy the system information text about your site, paste it into an email and send it to us at support at maxfoundry.com and mention ‘Installation fails in php 8’ in the subject.

    Thread Starter spiros

    (@spiros)

    I disabled the plugin WP-FFPC and it was installed.

    Plugin Author AlanP57

    (@alanp57)

    Ok, thank you.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.