Installation failed - aplus.net (11 posts)

  1. creativegal
    Posted 4 years ago #

    Installation failed, so I followed the instructions in the WordPress file and opened wp-config-sample.php in Notepad, edited and saved as wp-config.php. It directed to upload it, but the directions didn't say where exactly to place that file. I put it in the /public directory, which is where I uploaded all of the WordPress files. I tried opening the wp-admin/install in the browser and again received the message "Error: PHP is not running WordPress requires that your web server is running PHP. Your server does not have PHP installed, or PHP is turned off."

    I then tried placing wp-config.php in the wp-admin folder and opened wp-admin/install in the browser and received the same error message.

    My server does have PHP. I checked, and it is PHP5 and is enabled.

    Please help. I would use aplus.net's automatic WordPress installer, but with aplus.net it always tells me that WordPress cannot be installed to /public, so I end up having to put it in something like /public/blog, which I don't want.

    Thanks so much for your time.

  2. elfin
    Posted 4 years ago #

    you put the wp-config.php in the same directory that wp-config-sample.php resides.

    To test if php is running you could upload a simple php file:

    <?php phpinfo(); ?> (name something like test.php)

    and see if that shows anything. But I strongly suggest you then delete that file.

  3. creativegal
    Posted 4 years ago #

    Ok, that is the directory it is in now, and the installation failed. When you say to test it with a simple php file and "see if it shows anything," see if what shows anything?

    Under PHP management, aplus.net tells me PHP is enabled.

    My web site gives the following error when I try to bring up the URL: Error establishing a database connection.

  4. elfin
    Posted 4 years ago #

    earlier you said:

    "Error: PHP is not running WordPress requires that your web server is running PHP. Your server does not have PHP installed, or PHP is turned off."

    But the error you just mention isn't the same:

    Error establishing a database connection.

    the value you enter into wp-config may be incorrect, double check the database values.

  5. creativegal
    Posted 4 years ago #

    The error I just mentioned (Error establishing a database connection) is the error I get when looking at my domain in a web browser. The other error is the one I am given when I attempt to follow the directions in the WordPress file that say to open wp-admin/install in a web browser. It's still the same.

    I entered the values in wp-config exactly as the instructions directed. Not sure what else to do at this point. The only value I wasn't sure about was the MySql hostname. I thought that was mydomain.com . Would it be something different?

  6. elfin
    Posted 4 years ago #

    Ok back to my suggestion, what that file does is output the configuration of your server, but only if PHP is actually running and active.

    Obviously it needs to have a .php for the server to recognise it as a PHP script.

    But, it might be easier having a word with your web hosts and ask them to take a look for you - especially as your server config is stating php is active.

  7. Tara
    Volunteer Moderator
    Posted 4 years ago #

    An error connecting to your database is common, but it isn't necessarily a problem with wordpress itself.

    -First, double check your wp-config.php file settings for the database name, database username and database password. This is where most errors occur.

    -Then check that you don't need to change the database host from "localhost" to something else. Although many hosts use "localhost", but many do not.

    -Check you have actually created a database with the same database name as is in your wp-config.php file.

    -try clearing cache in your browser before viewing the updated page. To clear cache in your browser, press clrl+f5 keys simultaneously. Also, try different computers / different browser.

    -Last, but not least, if all that information is correct your database probably has a problem with it and you may need to contact your web hosting.

    This topic has already been raised many times on these forums. See:

  8. creativegal
    Posted 4 years ago #

    @Rich, thanks, but my web hosts (aplus.net) are idiots. When I sent a ticket to them today, they told me WordPress can't be installed to /public and closed the ticket. When I reopened it and told them of course it can be installed to /public and that I have another domain with it installed to /public, then another tech person said things were now fixed and the autoinstall would work to install to /public. Of course, it did not, and I found that whatever tech "support" had been in there had screwed things up and URL was now giving all visitors to my web site a 403 Forbidden error. The next tech person on the phone supposedly fixed that, only for me to later find she was redirecting the URL to a wrong address.

    In short, my web hosts are about the last people at this point that I'd want poking around under the hood. For everything they touch in an attempt to fix it, they break it and a few others. (Off topic, have a web host recommendation?) As stated, PHP is enabled and running. I'll probably end up having to pay someone to do this, which is a shame since I've got everything uploaded and just can't get the settings to work.

    @t-p Unfortunately, I've already tried the steps you listed. I also searched the forum before taking the time to create an account.

    Both of you, thank you for trying to help me get this working.

  9. esmi
    Forum Moderator
    Posted 4 years ago #

    Can you install WP successfully in a sub-folder of /public? If you can get an install up and running, it will only take a few tweaks for WP to take over the main domain without having to move everything.

  10. creativegal
    Posted 4 years ago #

    Well, it's finally up and running. Turns out aplus.net had given me the wrong MySQL hostname. Instead of sqlc40b.carrierzone.com it is sqlc40c.carrierzone.com. *sigh*

    Thanks again for your help.

  11. esmi
    Forum Moderator
    Posted 4 years ago #

    Glad to hear that you managed to get it resolved. :-)

    You asked about recommended hosting? There's a list of a couple of hosts on http://wordpress.org/hosting//hosting/ You could also run a quick search on "hosting" in these forums and get quite a list of good and bad host reviews.

Topic Closed

This topic has been closed to new replies.

About this Topic