Support » Installing WordPress » Installation error : Unkown column “wp_” in field list

  • damiensn

    (@damiensn)


    I’m beginning in wordpress and i’m trying to install it locally. But whan I install it, afetr completing, website title, email, password, i have the followings errors (Here is my apache logs) :

    [Tue Apr 27 21:06:27.513390 2021] [php7:notice] [pid 8832:tid 1204] [client ::1:58240] Erreur de la base de donn\xc3\xa9es WordPress Unknown column 'wp_' in 'field list' pour la requ\xc3\xaate SELECT wp_, referer: http://localhost/blog/wp-admin/setup-config.php?step=1&language=fr_FR
    [Tue Apr 27 21:06:27.523387 2021] [php7:notice] [pid 8832:tid 1204] [client ::1:58240] Erreur de la base de donn\xc3\xa9es WordPress Incorrect table name '' pour la requ\xc3\xaate INSERT INTO <code></code> (<code>option_name</code>, <code>option_value</code>, <code>autoload</code>) VALUES ('nonce_key', 'zBxcQt<code>bfZ7lIEP1..tb}<< Bf~bi/Rwit9/d,~n^r?|(eF+k%PU/o(Gf}|SXM)E', 'no') ON DUPLICATE KEY UPDATE</code>option_name<code>= VALUES(</code>option_name<code>),</code>option_value<code>= VALUES(</code>option_value<code>),</code>autoload<code>= VALUES(</code>autoload'
    ) faite par wp_print_scripts, wp_scripts, WP_Scripts->__construct, WP_Scripts->init, do_action_ref_array('wp_default_scripts'), WP_Hook->do_action, WP_Hook->apply_filters, wp_default_scripts, wp_create_nonce, wp_hash, wp_salt, update_site_option, update_network_option, add_network_option, add_option, referer: http://localhost/blog/wp-admin/setup-config.php?step=1&language=fr_FR
    [Tue Apr 27 21:06:27.524383 2021] [php7:notice] [pid 8832:tid 1204] [client ::1:58240] Erreur de la base de donn\xc3\xa9es WordPress Incorrect table name '' pour la requ\xc3\xaate INSERT INTO '' ('option_name', 'option_value', 'autoload') VALUES ('nonce_salt', ']w=)d,p;z3,]TH=,]vrRd<NrJ!Lv1T[TS96GJTp045$X3&*PvhG4E~6[*<~ WLhB', 'no') ON DUPLICATE KEY UPDATE 'option_name' = VALUES('option_name'), 'option_value' = VALUES('option_value'), 'autoload' = VALUES('autoload') faite par wp_print_scripts, wp_scripts, WP_Scripts->__construct, WP_Scripts->init, do_action_ref_array('wp_default_scripts'), WP_Hook->do_action, WP_Hook->apply_filters, wp_default_scripts, wp_create_nonce, wp_hash, wp_salt, update_site_option, update_network_option, add_network_option, add_option, referer: http://localhost/blog/wp-admin/setup-config.php?step=1&language=fr_FR
    [Tue Apr 27 21:07:12.523240 2021] [php7:error] [pid 8832:tid 1208] [client ::1:58251] PHP Fatal error:  Maximum execution time of 30 seconds exceeded in D:\\Programs\\Apache24\\htdocs\\blog\\wp-includes\\wp-db.php on line 2056, referer: http://localhost/blog/wp-admin/install.php?language=fr_FR
    [Tue Apr 27 21:08:27.454943 2021] [php7:notice] [pid 8832:tid 1208] [client ::1:58270] Erreur de la base de donn\xc3\xa9es WordPress Unknown column 'blog_' in 'field list' pour la requ\xc3\xaate SELECT blog_, referer: http://localhost/blog/wp-admin/setup-config.php?step=1&language=fr_FR
    [Tue Apr 27 21:08:27.461720 2021] [php7:notice] [pid 8832:tid 1208] [client ::1:58270] Erreur de la base de donn\xc3\xa9es WordPress Incorrect table name '' pour la requ\xc3\xaate INSERT INTO ' ('option_name', 'option_value', 'autoload') VALUES ('nonce_key', 'nl|Mfh(-Q^nX@_Z_w/z|1-s>~S?LKLxyqHARG6i%Vn$?]VYp&kjTe]iF1Sah!M-a', 'no') ON DUPLICATE KEY UPDATE 'option_name' = VALUES('option_name'), 'option_value = VALUES('option_value'), 'autoload' = VALUES('autoload') faite par wp_print_scripts, wp_scripts, WP_Scripts->__construct, WP_Scripts->init, do_action_ref_array('wp_default_scripts'), WP_Hook->do_action, WP_Hook->apply_filters, wp_default_scripts, wp_create_nonce, wp_hash, wp_salt, update_site_option, update_network_option, add_network_option, add_option, referer: http://localhost/blog/wp-admin/setup-config.php?step=1&language=fr_FR
    [Tue Apr 27 21:08:27.461720 2021] [php7:notice] [pid 8832:tid 1208] [client ::1:58270] Erreur de la base de donn\xc3\xa9es WordPress Incorrect table name '' pour la requ\xc3\xaate INSERT INTO ' ('option_name', 'option_value', 'autoload') VALUES ('nonce_salt', '[HRfHgp,y7M8vC,~n}|J)2d5(DG&MHAiqBnJoxU}uO@Z(U}b<.^Idu)4Gp/D<+.c', 'no') ON DUPLICATE KEY UPDATE 'option_name' = VALUES('option_name'), 'option_value' = VALUES('option_value'), 'autoload' = VALUES('autoload') faite par wp_print_scripts, wp_scripts, WP_Scripts->__construct, WP_Scripts->init, do_action_ref_array('wp_default_scripts'), WP_Hook->do_action, WP_Hook->apply_filters, wp_default_scripts, wp_create_nonce, wp_hash, wp_salt, update_site_option, update_network_option, add_network_option, add_option, referer: http://localhost/blog/wp-admin/setup-config.php?step=1&language=fr_FR
    [Tue Apr 27 21:09:12.524336 2021] [php7:error] [pid 8832:tid 1204] [client ::1:58275] PHP Fatal error:  Maximum execution time of 30 seconds exceeded in D:\\Programs\\Apache24\\htdocs\\blog\\wp-includes\\wp-db.php on line 2056, referer: http://localhost/blog/wp-admin/install.php?language=fr_FR

    NOTE : In logs, I’ve replaced ` by ‘ for wordpress forum formatting rules

    I have PHP 7.4.16, Apache 2.4, MySQL Community Server 8.0.23, and WordPress 5.7.1

    Can someone help me please ?

    • This topic was modified 1 year ago by damiensn.
Viewing 5 replies - 1 through 5 (of 5 total)
  • jjberry

    (@eltobiano)

    Hi Damien,
    First time I hear about this error.
    Looks like the setup process failed for some reason and you ended in a broken state.
    I’d suggest you to check if the file wp-config.php was created in the root of your site. If it is not there, you probably have a permission issue, meaning that the user under which php is executed doesn’t have write permission to that folder.

    IF wp-config.php file is there, I’d suggest to delete it and start the installation again.

    An important thing to check is if you DB user has enough permissions. Make sure you start with an empty DB and the user is granted proper access.

    Hope this helps. Let me know if you get it working.

    Take care

    Thread Starter damiensn

    (@damiensn)

    Thanks for a quick reply !
    I checked if the wp-config.php file was written and it was done. I also checked the database user settings. I have all the permissions. I also restarted with blank wordpress more than 3 times and it didn’t work.
    I think I found out what was causing the error.
    I have tried running SELECT wp_ in the mysql command line. It throws the same error as the one returned by wordpress.
    I also tried with simple quotes and it worked!
    So, I tested putting ‘wp_’ in the table prefix in the wordpress configuration interface. I can’t do this because wordpress told me that quotes are prohibited.
    I have tried modifying it directly in the wp-config.php file. I have the same message.
    So now the problem is how to add quotes to the table prefix.

    Thread Starter damiensn

    (@damiensn)

    I solved the problem to add quotes by commentig lines that verify if there is quotes (lines 286:289 and 319:322) in setup-config.php file. Now I can pass the first step and I haven’t got the error unkown column name wp_ in field list.
    Now I have an other error and I don’t kow how to fix it. It’s not caused by me when I commented setup-config.php, I already have got them before.
    Error logs :

    [Thu Apr 29 11:15:40.591913 2021] [php7:notice] [pid 10280:tid 1192] [client ::1:59039] Erreur de la base de donn\xc3\xa9es WordPress Incorrect table name '' pour la requ\xc3\xaate INSERT INTO '' ('option_name', 'option_value', 'autoload') VALUES ('nonce_key', 'M/B.zC0OuuB.PcdXr_cXQ,%-/S*_cW1dGD^V+GXL$VoI8]0Bk|_dHmT8;i6t^k{5', 'no') ON DUPLICATE KEY UPDATE 'option_name' = VALUES('option_name'), 'option_value' = VALUES('option_value'), 'autoload' = VALUES('autoload') faite par wp_print_scripts, wp_scripts, WP_Scripts->__construct, WP_Scripts->init, do_action_ref_array('wp_default_scripts'), WP_Hook->do_action, WP_Hook->apply_filters, wp_default_scripts, wp_create_nonce, wp_hash, wp_salt, update_site_option, update_network_option, add_network_option, add_option, referer: http://localhost/blog/wp-admin/setup-config.php?step=1&language=fr_FR
    [Thu Apr 29 11:15:40.592912 2021] [php7:notice] [pid 10280:tid 1192] [client ::1:59039] Erreur de la base de donn\xc3\xa9es WordPress Incorrect table name '' pour la requ\xc3\xaate INSERT INTO '' ('option_name', 'option_value', 'autoload') VALUES ('nonce_salt', '.W.vdU yx}YBIp0+6=b#^; ^Z#g$vBb%x>je&{=]6ZF%_@}V-8^4O6McGGL!3WI)', 'no') ON DUPLICATE KEY UPDATE 'option_name' = VALUES('option_name'), 'option_value' = VALUES('option_value'), 'autoload' = VALUES('autoload') faite par wp_print_scripts, wp_scripts, WP_Scripts->__construct, WP_Scripts->init, do_action_ref_array('wp_default_scripts'), WP_Hook->do_action, WP_Hook->apply_filters, wp_default_scripts, wp_create_nonce, wp_hash, wp_salt, update_site_option, update_network_option, add_network_option, add_option, referer: http://localhost/blog/wp-admin/setup-config.php?step=1&language=fr_FR
    jjberry

    (@eltobiano)

    I’ve run out of ideas.
    Your change to support quotes isn’t really a solution. The SQL query is malformed for a different reason. Adding the quotes may help you skip the first error, but the site won’t work. The problem here is related to configuration and not caused by WP code, I can guarantee you that.

    There is something in your local server environment that is not working as expected. I’d suggest you to use a tool based on containers for you local envs. A popular one is https://localwp.com/ . It is really cool, easy to use from a GUI but also provides you access to the container if you want to dig into more technical stuff.

    Thread Starter damiensn

    (@damiensn)

    Thanks for the help ! I wanted to install all the components separately to find out what I installed, but I resigned myself to using easyphp and wordpress works!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Installation error : Unkown column “wp_” in field list’ is closed to new replies.