WordPress.org

Support

Support » Installation » Installation Error – database name incorrect

Installation Error – database name incorrect

  • I’ve been using blogger.com and want to upgrade. I learned html and css last month (well, ok, I think I have html down, and css I can stumble through). I know -0- php, but part of the reason I want to switch is to learn php.
    I have a domain name at http://chasingthewind.net, hosted by GoDaddy.com. I’ve verified they support php 4.1 or greater and mysql 3.23.23 or greater.
    I click on “databases”, “add a database”. It asks me for a username (I choose “c_admin”) and a password (“123”). After a few minutes, GoDaddy tells me mySQL database is active.
    Host name = mysql7.secureserver.net, username=c_admin, size 0MB. There’s an “open manager” button that tells me my database is c_admin, no tables found in database, and gives me an option to create a new table on c_admin (I can select “Name” and “Fields”). I don’t know what to put here, I’m assuming WordPress will take care of this during installation.
    In my wp-config.php file, I write:
    // ** MySQL settings ** //
    define(‘DB_NAME’, ‘c_admin’); // The name of the database
    define(‘DB_USER’, ‘c_admin’); // Your MySQL username
    define(‘DB_PASSWORD’, ‘123’); // …and password
    define(‘DB_HOST’, ‘localhost’); // 99% chance you won’t need to change this value
    When I run the install.php, I get this:
    Error establishing a database connection! This probably means that the connection information in your wp-config.php file is incorrect. Double check it and try again.
    Are you sure you have the correct user/password?
    Are you sure that you have typed the correct hostname?
    Are you sure that the database server is running?
    Am I suppose to do something with that table? Is the hostname the same as the name of the database? I don’t know where to go from here.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Mark (podz)
    Support Maven

    @podz

    “mysql7.secureserver.net”
    That looks like the mysql, but not a database within it.
    If you have phpmyadmin, open that up and check the db name.
    Or contact your hosting co and see what they say.

    After I changed my db_host entry as you suggested, the installation went flawlessly.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Installation Error – database name incorrect’ is closed to new replies.