Support » Installing WordPress » Install won’t work – 404; page cannot be found

  • So, I’ve done everything I’m supposed to. I have downloaded, unzipped, edited config and uploaded to my server. I have done this once before on my other website, and then it worked. Now, I’ve tried several times and no can do. Not even on my old domain, where it used to be ok.

    When I try to enter wp-admin/install, I only get a 404: page cannot be found.

    I’ve tried both subcategory and straight into the domain. Still no success.

    What to do..?

Viewing 14 replies - 1 through 14 (of 14 total)
  • What is the domain you are trying to install too. What is the folder structure (did you upload WP to the root or in a /worpress folder or /blog?

    I tried installing it to, and it won’t work either way.

    Right now it’s at – or would have been, if I could get it to work. :/

    1. delete your wp-config.php file. try to re-install.


    2. WordPress requires PHP + MySQL. Right? You have PHP and MySQL installed on IIS right?


    3. Google: install wordpress iis help

    let me know where you are, i want to write a tutorial to help many users like you shortly.

    1. Still won’t work.

    2. Right. Like I said, it used to work. I think it might be the new version that is causing the trouble..?

    3. Uhm… huh..? 🙂

    I’m in Norway.

    I am having the same result with my install of WordPress wp_config.php file: I opened the uploaded file to edit any errors I may have made but the entries were correct e.g. DB_NAME, DB_USER, DB_PASSWORD could the next line have anything to do with the error 404 result?

    define(‘DB_HOST’, ‘localhost’); // 99% chance you won’t need to change this value

    ??? Uploading to cPanel X on midPhase servers.

    I don’t know if this is related (and it is definitely not a solution); I install using the svn method. I have installed WP many times – quite successfully. Last night I tried to install a new copy. I get an error 500 ( server misconfiguration or somesuch problem); I have removed and reinstalled the 2.3.3 files 3 times now. No luck.

    I’m beginning to wonder if there is something wrong in the repository. If I remove my wp-config.php, I get the screen that tells me that. In desperation, I let WP create me one using the online method. All was ok until I clicked Install – back to the Server Error 500.

    I had the same error as the first guy. Make sure that when you are uploading the wordpress file it is in just one file – like “online blog” and paste all of your wordpress stuff there. Make sure that this file is on the desktop, I changed it to this instead of WordPress/Wordpress2.6/Worpress2.6/Wordpress and it fixed the first guys error. So just make sure all your stuff you are trying to install is on the desktop and in one folder and then try it.

    I’m having the same issue. I’ve done the same stuff.

    No worky.

    Something up with the latest version of WP?

    you should not have to edit the wp_config.php file when you are upgrading..Don’t touch that file!
    If you follow the upgrade steps to the letter
    that are here:
    you should not have a problem…

    Here’s the steps I take to upgrade WordPress:

    1)back-up the database ! I use this plugin:
    2)deactivate all plugins
    3) over-write all WordPress files in the WordPress root directory except wp-config.php and .htaccess
    4)delete old wp-includes directory and all files within it. FTP new version wp-includes directory and all files within in
    5) delete old wp-admin directory and all files within it and FTP new version wp-admin directory and all files within it.
    6)type in http://yourdomain-and-wordpress-url/wp-admin/upgrade.php and follow the prompts
    7) you’re done! login and activate all your plugins and upgrade the ones that indicate they need to be upgraded.

    now, there still could be problems, and it may be your theme that’s not compatible. In which case change to the default theme. Is your site working? Yes? okay, now you must change themes or contact the theme designer and see if they have an upgraded version.

    Sometimes it could be a problem with a plugin. To check you must de-activate and activate plugins one by one to determine which one is causing you grief.

    Good luck!

    Who said anything about upgrading? We’re trying to do a clean install.

    It’s not working. I’ve removed and uploaded all files again and again. I’ve checked and rechecked the DB info.

    Everything checks out. But wp-admin/install.php = 404

    Alright, it seems WinZip was corrupting files.

    I decompressed using a different program, removed all files from the server, uploaded all the newly decompressed files, and all is well.

    This included the fact that I downloaded 2.6 again, just in case.

    My next trick is importing everything without losing anything.

    So far, it’s stuck in Jan. ’08. It’s Freakin’ July!

    I tried install v 2.6 and got a 405 msg. (not 404) Anyway once I’d done everything I could, I contacted the help desk at my hosting co. (crystal Tech) They advised that they have had several similar complaints and the only “work around” they have so far is to uninstall v 2.6 and install v 2.5.1 instead. I am in the process of doing that now and will tell you if it works out. If it does, then the problems with the new version.




    I’m a newbee to WordPress; I’ve installed WordPress to the root of my server, updated the wp-config.php file to enter the proper DB UN, PW and local host (basically did everything I was suppose to do) and I’m getting a 404 error when I try to access the WordPress back end i.e. – Huldremor were you able to find a solution to this problem? If not can anyone please help?



    So, you uploaded all the files to your root and then went to and followed the instructions to install? But now you can’t login to the admin panel?

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Install won’t work – 404; page cannot be found’ is closed to new replies.