WordPress.org

Support

Support » Installation » Install trouble with install.php – Error on Line 52

Install trouble with install.php – Error on Line 52

  • Just uploaded the wordpress files to my site, edited the config and tried to run install.php, and I received this error:

    Fatal error: Call to a member function on a non-object in /”url pathway”/wp-admin/install.php on line 52

    I’ve searched the forums but haven’t found any advice that has fixed the problem. Do I need to alter the config in another way? Do I need to do anything else to my database, other than what’s outlined in the installation notes? I’m only trying to start a single blog as a test, but do I need to edit the table prefix at all?

    Any help is greatly appreciated, as I’m anxious to get started with WordPress as my blog software.

    Thanks in advance for the help!

Viewing 9 replies - 1 through 9 (of 9 total)
  • What version of WP are you working with? What kind of a server setup are you installing on?

    Sorry ab0ut that…I downloaded the most recent version of WP, and the server has:

    PHP version 4.3.10
    MySQL version 4.0.22-standard

    I’m trying to do a basic install in a subdirectory.

    “The most recent version…” does that mean 1.2.2 or one of the 1.5 BETA versions?

    Version 1.2.2

    Originally, I had the database name set as “wpress” and the database username set as “wpress” as well. Thinking that this might screw with things, I changed the username to “wpblog”, but I’m still getting the same error message.

    Really hope I can get this worked out…

    So, last night I wiped 1.2.2 from my server, downloaded 1.2.1 and uploaded it.

    Boom. Worked perfectly.

    WordPress looks absolutley beautiful, and I’m already digging the functionality. Now it’s off to the How-To forum to figure out the whole multi-blogging thing.

    Moderator James Huff

    @macmanx

    Now, try upgrading to WP v1.2.2. Believe me, if you stick with v1.2.1, you’re leaving yourself open to some nasty exploits.
    http://codex.wordpress.org/Upgrading_WordPress

    I’m getting the exact same error on line 52 in install.php 🙁 I downloaded version wordpress-1.2.2.zip on 1/14/05 and my PHP Version is 4.1.2. Help what should i do ???

    Well solved the problem. The new config.php had a size of 0. I fpt’d it again and the install worked like a charm. Thanks Podz, whoever you are 🙂

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Install trouble with install.php – Error on Line 52’ is closed to new replies.
Skip to toolbar