WordPress.org

Support

Support » Installation » Install to subdirectory not working

Install to subdirectory not working

  • Hi,
    I am trying to install the latest version (2.01) to mysite/blog and it succeeds to install fine, with no errors. When I try to login to the administrator, I get a 404 error because it is trying to access file mysite/wp-admin/profile.php instead of mysite/blog/wp-admin/profile.php. When I try to go back to the blog page it is a blank screen.

    I tried installing to the root and everything works fine. I tried several times to install to a subdirectory, running the install from another machine and from the same machine via localhost. Both installs finish correctly, but the same result, the subdirectory is missing from the path. If I add it to the url, it just displays a blank screen.

    I am installing on windows with apache, php and mysql. I tried with and without mod_rewrite. Anyone know the trick to getting this to install properly in a subdirectory?

    Thanks.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Is this a hosted environment or you are your own host?
    All my blogs are in subdirs (or subdomains), so I don’t see any reason why it wouldn’t work.

    One thought: maybe fisrt time it was installed in the root and you are trying to install it in a subdir AND using the same database – without changing the 2 URIs in the Options.

    It is my own machine and I wiped the directories between installs and re-unzipped from scratch.

    I tried wangxiaohu’s solution for performance problem (disabling cache mechanism) and now my installs to a subdirectory are working. Does this make sense to anyone why the cache would break the install?

    wangxiaohu’s solution to performance problem:
    —————
    Disabling the cache system solved the problem. In wp-config.php:

    define(‘DISABLE_CACHE’, true);
    —————

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Install to subdirectory not working’ is closed to new replies.