Install Script not working (5 posts)

  1. drewfansler
    Posted 1 year ago #

    Recently, my site was hacked and I moved it to iPage.

    When attempting to run the install script (http://drewfansler.com/wordpress/wp-admin/install.php), I receive this message.

    "Error establishing a database connection
    This either means that the username and password information in your wp-config.php file is incorrect or we can't contact the database server at localhost. This could mean your host's database server is down.

    Are you sure you have the correct username and password?
    Are you sure that you have typed the correct hostname?
    Are you sure that the database server is running?"

    Username/password are correct.
    hostname is correct.

    I have the following connection code snippet:

    $link = mysql_connect('drewfanslercom.ipagemysql.com', 'drewfanslercom', '*password*');
    if (!$link) {
    die('Could not connect: ' . mysql_error());
    echo 'Connected successfully';

    It looks like the database is running. If the password and user ID are correct, does anyone have any insight as to why the install script can't or won't run?

    Thanks in advance.

  2. Hardeep Asrani
    Posted 1 year ago #

    If your database info is right, and it's still not working, then you should contact your hosting provider. Which one are you using?

  3. drewfansler
    Posted 1 year ago #

    I'm using iPage.

  4. Hardeep Asrani
    Posted 1 year ago #

    Delete old install & follow this post: http://www.ipagereviewtraining.com/website-setup/ipage-wordpress-setup/

    It it's still not working, contact iPage customer support.

  5. JumboClicks
    Posted 1 year ago #

    I would remove all the core files and plugins and you really need to look closely at your theme for any bad code they may have inserted.

    the old version of wordpress install files can be found here


Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.