Install remote plugin, upgrader adding .tmp to folder (8 posts)

  1. msolution
    Posted 3 years ago #

    im trying to upgrade my own plugin, and install another plugin,

    it installs ok, but it adds .tmp in the folder name of the plugin some of the times.

    what is supposed to be




    my code is simple,

    $upgrader = new WP_Upgrader(new my_plugin_skin());
    $plugin_url = @$upgrader->run(array(
    			'package' 	=> $download_link,
    			'destination' 	=> $destination,
    			'clear_destination'=> $clear_destination,
    			'clear_working' => true,
    			'is_multi' => true,
    			'hook_extra' 	=> array()
  2. msolution
    Posted 3 years ago #


  3. msolution
    Posted 3 years ago #

    anyone please :)


  4. reghyz
    Posted 3 years ago #


    Have you found an answer ? i have a similar problem, are you instaling this plugin from wordpress.org ? or from a another local or remote path (it append for me only in this cases) ?

    a tip i've found but alas didn't solved my problem was linked to the wp wpcontent/upgrade/ folder authorizations, try to pass it to 777 instead of 755, maybe this could help with you issue ...

  5. msolution
    Posted 3 years ago #

    i have php as cgi, so default permissions are 755,

    if some one could shed some light here

  6. Stephen Harris
    Posted 3 years ago #

    I was experiencing the same issue. In my case, I was being a little bit stupid. I was serving the zip from an Amazon S3 account, but the zip simply contained the plug-in files. Instead, should be placed inside a folder, which is then zipped.

    Presumably when WordPress unzips the plug-in files, it creates the .tmp folder for them - at least replacing the zip with one with a proper structure seems to fix it for me.

  7. msolution
    Posted 3 years ago #

    i did the same, plugin files inside a folder, and then zipped,

    if i use the wordpress upload plugin panel, alls well,
    but try it remotely,... things dont work well.

  8. nvartolomei
    Posted 2 years ago #


    anyone solved this? Also installing from remote location != wordpress.org.

Topic Closed

This topic has been closed to new replies.

About this Topic