Support » Installing WordPress » install.php 500 internal server error

  • Resolved kalmanfinger

    (@kalmanfinger)


    Making a clean install on my local machine.
    OS: Arch Linux

    So I’ve made a basic setup following Arch guides and have an *almost* working setup with Apache and MariaDB. When I go to “http://hostname/wp-admin/install.php” and fill out the db info I get 500 internal server error.

    Then I tried manually setting up wp-config.php and after I save it, I get 500 internal server error on any WordPress page. Simple “test.php” page with “phpinfo();” works just fine.

    I guess my problem is with the database. As I said, I followed Arch guides and have MariaDB installed. I can log into the database in terminal with credentials I provide to WordPress, no problem. So I am not sure what the issue is, maybe some weird permission problem.

    Need help, thank you in advance.

    • This topic was modified 3 weeks, 1 day ago by  kalmanfinger.
Viewing 5 replies - 1 through 5 (of 5 total)
  • Hi,

    You should check the log files for more details about this.

    If you see any error in the Apache log files please provide us with with the error message and I will try to help you.

    Also, you can enable WordPress debugging and see if that will help you to locate the problem. More information about how to enable WordPress debugging you can find at: https://codex.wordpress.org/Debugging_in_WordPress

    hey,
    I’m having a problem while installing WordPress on my subdomain and unable to open it.
    carryonfeed

    Keith

    (@keithdriscoll)

    @carryonfeed As per forum rules please create your own topic. There is also no need to post a working URL, as it can be flagged as spam 🙂

    Keith

    (@keithdriscoll)

    Oops, forgot to tag modlook 🙂

    Thank you for your responses!

    I accidentally fixed this. The issue was that I was trying to use php-fpm instead of libphp7.so. After I replaced this in my server config, WordPress worked just fine. If you are interested in the exact cause I can install php-fpm again and provide you with the error logs.

    Thanks again!

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.