Support » Installation » Install Help!

Install Help!

  • I have spent the last three hours on the 5 min install. I have checked everything again and again, password – hostname, database name etc, and I always get the same result “Error establishing a database connection!” I even created another database and went through the whole process with the same result.
    This is the setting for the install http://www.wilfjames.com/fop/wp-admin/install.php
    My hosting Company has PHP4.1.2 & mySQL3.23.38
    Is there something I am missing that I should be looking at?
    Help please.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Can you email your host asking for specific details for connecting to mysql ?
    Other things to check:
    – that your ‘username’ is correctly associated with mysql
    – that there are no spaces before or after any on the info that you have put into wp-config.php
    – that your username has all priviledges.

    OK I will. It’s late where I am so probably tomorrow before I get anything back. I did of course check the other posts before jumping in. I have also checked (again) that there are no spaces before or after any of the info that I put into wp-config.php.
    Could you give a bit more of an explanation regarding:
    – that your ‘username’ is correctly associated with mysql
    – that your username has all priviledges
    Thanks for your help.

    Could you explain what this means Kevin
    2. create username
    3. add username to database??

    What user interface have you got there eg phpmysqladmin or what?

    This is at the top of the interface when I open the phpMyAdmin:
    Welcome to phpMyAdmin 2.5.5-pl1
    MySQL 4.0.16-standard running on localhost as my55505@localhost
    Here is the wp-config.php:
    /** WordPress’s config file **/
    /** http://wordpress.org/ **/
    // ** MySQL settings ** //
    define(‘DB_NAME’, ‘my55505’); // The name of the database
    define(‘DB_USER’, ‘my55505’); // Your MySQL username
    define(‘DB_PASSWORD’, ‘*****’); // …and password
    define(‘DB_HOST’, ‘localhost’); // 99% chance you won’t need to change this value
    // Change the prefix if you want to have multiple blogs in a single database.
    $table_prefix = ‘wp_’; // example: ‘wp_’ or ‘b2’ or ‘mylogin_’
    // Change this to localize WordPress. A corresponding MO file for the
    // chosen language must be installed to wp-includes/languages.
    // For example, install de.mo to wp-includes/languages and set WPLANG to ‘de’
    // to enable German language support.
    define (‘WPLANG’, ”);
    /* Stop editing */
    $server = DB_HOST;
    $loginsql = DB_USER;
    $passsql = DB_PASSWORD;
    $base = DB_NAME;
    define(‘ABSPATH’, dirname(__FILE__).’/’);
    // Get everything else
    It must be something simple for me to do or change to get wordpress to run – anybody got any ideas?

    Does no one have any suggestions as to what I might try??

    I must fall into the 1% who need to change “localhost” to the IP address of my host.
    I slowly worked through the settings changing one thing at a time and eventually the “wp-admin/install.php” did its thing and I was in. From there a very simple setup. And yes it took 5mins!!
    Wilf James.

    I tried this, and it didn’t work 🙁

    “I tried this, and it didn’t work :(“
    I am no expert, but I have found when the likes of WordPress say it’s a 5 minute install, that’s what it is!!
    However I worked slowly through all the changables until I found the correct combination. Bingo! When I got it right it took just under 5 minutes for the install to happen.
    I am still working on getting the formula for my PHOTOBLOG correct. I am getting there. My first few enteries can be seen here.
    : http://www.focusonparis.com
    Hope you get up and running soon.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Install Help!’ is closed to new replies.
Skip to toolbar