Support » Installation » Install fails, gives msg: ‘line1: ?php: No such f

Install fails, gives msg: ‘line1: ?php: No such f

  • I ran wp-admin/install.php, and received these error messages:
    wp-admin/install.php: line1: ?php: No such file or directory
    wp-admin/install.php: line 2: =; command not found
    wp-admin/install.php; line 3: syntax error near unexpected token '../wp-config.php' '
    wp-admin/install.php: line 3:
    if (!file_exists(‘../wp..config.php’)) ‘
    Any idea what’s wrong and how to fix?

Viewing 11 replies - 1 through 11 (of 11 total)
  • Do you have php installed on the server ?
    To find out, do this:
    Paste this into a new Notepad / BBEdit file
    <?php phpinfo(); ?>
    Save as ‘info.php’
    Upload to server. Visit in your browser – http://www.example.com/info.php
    That will give you info about your php version.

    Php is installed, as is MySQL and versions meet requirements.

    Were the files uploaded in Binary mode instead of ASCII mode ?

    Hmm, don’t know…I’ll check. This is on a rh9 box…can’t remember how I unpacked/installed WordPress…rpms? tar.gz? I’ll have to look at the Worpress docs…

    Any updates on this? I’m having the exact same problem.

    Two issues cause this:

    1 – PHP is not actualy installed on the server.
    2 – the file has been incorrectly uploaded as mentioned above.

    What steps have you tried ?

    I’m using a hosted server, if that makes any difference.

    When I run “php -v” is says: PHP 4.3.3 (cgi) (built: Sep 1 2003 04:45:21) so I’m assuming that’s it’s installed and running and I have phpbb running successfully.

    I’ve tried:
    –unzipping the .zip file on my workstation and uploading it in text mode
    –unzipping the .zip file on my workstation and uploading it in binary mode
    –uploaded the .gz file and untarred it on my server.

    I get the same error every way that I did it.

    Thanks for your help.

    Have you maintained the integrity of the folder/directory structure when decompressing the archives?

    I used “tar zxvf” on the server and “use directories” in winzip on my workstation.

    It looks like the directories are all there and similar to the way it looks when I unzip in on my workstation.

    I’m not very smart :-(. I was trying to run install.php from the console.

    I ran it from my browser and it’s working now.

    Thanks for tolerating me.

    Thanks for sharing that information, frschoenfeld. That gives us another question to ask in the future, should someone else run into the same issue.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Install fails, gives msg: ‘line1: ?php: No such f’ is closed to new replies.