Support » Plugin: Site Reviews » Install Fails?

  • Resolved Chris Perryman

    (@revconcept)


    Tried to install from repo and got a failure, thought it could be the new version so I pulled an older version from another site we have running it…get the same error:

    Plugin could not be activated because it triggered a fatal error.

    Parse error: syntax error, unexpected T_STRING, expecting T_CONSTANT_ENCAPSED_STRING or ‘(‘ in /home/haunt11/public_html/domain.net/wp-content/plugins/site-reviews/site-reviews.php on line 25

Viewing 11 replies - 1 through 11 (of 11 total)
  • Thread Starter Chris Perryman

    (@revconcept)

    Some more info – tried disabling all plugins and switching to 2017 theme…same behavior.

    Have since installed this on another site with no issue. Odd thing is, all three sites we are using/trying to use on are essentially clones of each other: same server environment, same theme etc.

    Any ideas?

    Thread Starter Chris Perryman

    (@revconcept)

    Some more info – tried disabling all plugins and switching to 2017 theme…same behavior.

    Have since installed this on another site with no issue. Odd thing is, all three sites we are using/trying to use on are essentially clones of each other: same server environment, same theme etc.

    Any ideas?

    Plugin Author Gemini Labs

    (@geminilabs)

    Sorry, I missed this post.

    What version of PHP are you using on this server?

    Plugin Author Gemini Labs

    (@geminilabs)

    Has the plugin copied over correctly? Have you tried deleting the plugin and installing it manually? If you are installing from a git repo which includes the plugin, you may want to check that it hasn’t been modified.

    • This reply was modified 3 years, 10 months ago by Gemini Labs.
    Thread Starter Chris Perryman

    (@revconcept)

    I’ve tried both installing from the repo/in WP and putting the files up manually via FTP

    Plugin Author Gemini Labs

    (@geminilabs)

    Any chance you can give me access to view for myself? You can also email directly to site-reviews @ geminilabs.io

    Thread Starter Chris Perryman

    (@revconcept)

    Sorry I missed you PHP question, but I also noted in the email I just sent:

    5.4 something? I know that’s old and I’m trying to get them to update. But FYI both other sites are using the same and it’s fine. Do you think that’s the problem tho?

    Plugin Author Gemini Labs

    (@geminilabs)

    Ok the problem is that your website is running on PHP 5.2.17

    Site Reviews requires a minimum of PHP 5.4 to function.

    You can see your System information in the WooCommerce plugin that you have installed (System Status page).

    Plugin Author Gemini Labs

    (@geminilabs)

    Recommended to use a minimum of PHP 5.6. Almost every hosting provider (at least any that are worth using) will provide PHP 5.6 at a minimum, the better ones will also offer PHP 7.0. Chances are it’s only a phone call or a support request away for them to change it.

    Thread Starter Chris Perryman

    (@revconcept)

    So odd – it’s telling me in cPanel it’s 5.4!!!

    I’ll contact the host and get it sorted. That’s really annoying and I’m sorry we bothered you!

    Plugin Author Gemini Labs

    (@geminilabs)

    Not a problem, happy to help!

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Install Fails?’ is closed to new replies.