Support » Installing WordPress » install error: “already installed”

  • Grinch


    hey guys,

    today i screwed up my localhost-install of WP. the admin passy was somehow lost and there was no way to login (f*ck !). so i deleted my XAMPP lite install (and with that, my local wordpress install).
    after a reboot and reinstall of both xampp (= apache, mysql, php) and wordpress, i cant get the fresh wordpress up and running.
    i get the error
    “Already Installed
    You appear to have already installed WordPress. To reinstall please clear your old database tables first.”

    rest of the error page is filled with code (another error, that is).

    help ?! what can i do now ? did i forget to deinstall something ? some nifty windows system service ?

    thx, mr. grinch

Viewing 11 replies - 1 through 11 (of 11 total)
  • Les Bessant


    keeper of the Tiggers

    When you uninstalled XAMPP, did you actually delete the MySQL database? Sounds like it’s still using the same one.

    And if you have got the db, you can reset the password:



    i deleted the database, and then reinstalled XAMPP. no effect.

    atm, i got XAMPP uninstalled. is there a way to check if the / any mysql database is still alive ?

    … fuckin hell, if i only looked first; think i could have reset the passy with ur help 🙁



    this is the error msg … help !!

    Moderator James Huff


    Grinch, it looks like PHP was not configured properly. If you are attempting to install WordPress locally using XAMPP, see this:



    I got exactly the same error on a local install because I’d used the latest version of MySQL v4.1…. fixed by rolling back to v4.0.

    There is a link somewhere (need to find it) about WP not working well with MySQL v4.1, it certainly didn’t work in my case, but ran without probs on v4.0.

    OK here’s the link, look at section “Downloading and Installing MySQL”

    I’m sure the gurus on here will advise differently if there is a fix (I’m just a newbie)

    Best Regards,

    Moderator James Huff


    Wp does not work work well with MySQL v4.1.7, but it works well with all other versions above 4.0, including v4.1.8 and higher.



    I get exactly the same error message as in the link above.

    However, I am using SQL4.0 so don’t understand why there is a problem.

    I confirmed with my hosting service that my config file was correct. (Note: it was incorrect when I first installed. I then simply deleted the WordPress folder from my FTP site, and pasted it again, and re-installed. No luck).

    how can I clear it out completely, and then re-install? My server information:

    Software support:
    • Full range of MIME Types supported
    • Flash/Shockwave
    • CGI counter, date and time fields
    • CGIEMAIL (form handling code)
    • PHP4 & 5
    • Chili!Soft ASP
    • MySQL 4.0
    • Telnet/ SSH
    • FrontPage 2002 Extensions
    • Support for SSI
    • CGI counter, date and time fields
    • Perl 4 & 5
    • Custom CGI
    • C, C++, C compiler



    jayhen: same error message as in the link above

    Which one? There are so many links above…
    You mean the “already installed” error? Drop the tables from your DB, upload (and don’t paste:) the WP files to the server and run the install.php.



    still, the issue is NOT resolved !!
    i installed everything from scratch again. fresh xampp lite with mysql 4.1.12 and php 5.0.4, fresh wordpress install. the wordpress database is empty.

    so just WHY do i get the “already installed” error ?! … “pls clear ur old database table” is just not workin.

    heeeelp !

    Moderator James Huff


    Grinch, if you have a PC, please follow these instructions exactly:

    If you have a Mac, please follow these instructions exactly:

    We have heard of no WordPress-related troubles with either of those tutorials, considering that you follow the process(es) exactly as written from the first step to the last.



    well i did !!
    only thing not working like the tutorial is creating the datatbase with “utf8 unicode ci” options, because its with underscores “utf8_unicode_ci”.

    did the rest exactly. no success !!

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘install error: “already installed”’ is closed to new replies.