Support » Installing WordPress » Install error

  • After I uploaded wordpress, when I try to execute the install file I get the following error:

    Warning: main(/home/content/j/o/h/johnfolsomjr/html/blog/wp-includes/wp-db.php): failed to open stream: No such file or directory in /home/content/j/o/h/johnfolsomjr/html/blog/wp-settings.php on line 69

    Fatal error: main(): Failed opening required ‘/home/content/j/o/h/johnfolsomjr/html/blog/wp-includes/wp-db.php’ (include_path=’.:/usr/local/lib/php’) in /home/content/j/o/h/johnfolsomjr/html/blog/wp-settings.php on line 69

    Any Ideas?

Viewing 8 replies - 1 through 8 (of 8 total)
  • never mind, I figured it out. Thanks

    I’m having the same problem with my website. Do you mind me asking, how you fixed it? I have been trying to figure it out for hours, and I don’t know what it is. I never had this problem before. Any help would be appreciated!

    That is generally caused by the web server not being able to open the include files. Check the permissions of the files and the directories they are in.

    “Check the permissions of the files and the directories they are in.”

    Huh? I’m having the same issue and haven’t a clue where to look, or what to do.

    What do you mean by permissions. I’m sorta new to wordpress, so i don’t understand what you are saying. I’m soo lost. haha.

    You will need to know a little bit about the environment the site is hosted on.

    Doing a directory listing using FTP will give you the permissions of the files in the directory. In some badly set up environments the files you upload may be owned by your user id, however the web server may be running as a different user id, meaning that the web server may not be able to open the files.

    You can fix this by making the files readable by all users, to do this using FTP you can use the “CHMOD” ftp command.

    Assuming your host is unix (sorry, I don’t know anything about Windows, and your host is more likely to be unix). Permissions will look like:

    -rwx——

    ignore the first – for the moment, the next 9 are three sets of three. The first 3 for the userid who owns the file, the second for the groupid that owns the file, the third set is for the rest of the world. You’ll probably want to make sure the rest of the world has read access, you can do this with the command:

    CHMOD o+r

    If the listing is a directory it will start with a “d” in the first space, in this case you will need to do a:

    CHMOD o+x

    as well on the directories, as under UNIX directories need “execute” permissions in order to open the contents of.

    You can find a little bit of info in the Codex at:

    http://codex.wordpress.org/Changing_File_Permissions

    A really good guide to FTP clients and some detailed info on file permissions can be found at:

    http://www.interspire.com/content/articles/12/1/FTP-and-Understanding-File-Permissions

    I had the exact same error. When I unzipped my WordPress2 folder for some reason wp-settings.php was not there.

    Make sure you have that file in your WordPress install’s root folder and that will probably fix it.

    k. Thanks guys!! I will try both. Thanks again, for the fast responses. 🙂 I hope this works! 🙂

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Install error’ is closed to new replies.