Support » Plugin: Asgaros Forum » Install different language

  • Resolved tomatito

    (@tomatito)


    Hi, first of all great plugin. I have two questions:

    1. How can I install the Dutch language pack? If there is any?

    2. How can I join to make translations to my native speak (Dutch)?

    (I have found info about this, but not useful to me… )

    Thanks in advance for your reply.

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author Asgaros

    (@asgaros)

    Hello @tomatito

    1. How can I install the Dutch language pack? If there is any?

    It seems there is a Dutch language pack (which is not 100% complete). Just set your WordPress language in your WordPress settings to Dutch and then go to the Updater to download the language files.

    2. How can I join to make translations to my native speak (Dutch)?

    You can help to add translations for Dutch (Stable latest release) here:
    https://translate.wordpress.org/locale/nl/default/wp-plugins/asgaros-forum

    When you are used to it on how to add new translations you can leave me a message here so I can request you as an Translator for Dutch so you can approve your own translations directly.

    Greetings,
    Thomas

    I would like to translate this plugin to my regional language Malayalam. How will i do that

    Plugin Author Asgaros

    (@asgaros)

    You can help to translate Asgaros Forum on this site: https://translate.wordpress.org/projects/wp-plugins/asgaros-forum. Please only use this site and dont send me your own .po/.mo files because it is hard to maintain if I get multiple translation-files for a language.

    I’m trying to put my translation on plugin, but I can’t…
    How do I rename my files to make them work?
    I’m from Brazil…

    Plugin Author Asgaros

    (@asgaros)

    Hello @cleudemirjunior

    First you have to change the language of your WordPress installation to the one you want to use.

    You have to place your language files in the following folder (example for de_DE):

    – wordpress\wp-content\languages\plugins\asgaros-forum-de_DE.mo
    – wordpress\wp-content\languages\plugins\asgaros-forum-de_DE.po

    @asgaros I tried this solution, but it doens’t work…
    In my folder I have the following files:
    -asgaros-forum-pt-BR.mo
    -asgaros-forum-pt-BR.po
    -asgaros-forum.mo
    -asgaros-forum.po
    -asgaros-forum.pot
    I have to keep te files, or should I remove one of them?

    Plugin Author Asgaros

    (@asgaros)

    @cleudemirjunior

    Only keep the first two of them. Are you sure that they are in the correct folder? Are you sure that you set the correct language in WordPress?

    @asgaros, yes…
    I double check this… The language is correct.
    However I keep only the files
    -asgaros-forum-pt-BR.mo
    -asgaros-forum-pt-BR.po

    and still not working. There might be a conflict between some plugins?

    Plugin Author Asgaros

    (@asgaros)

    Maybe, you could try to disable other plugins to see if its working (especially language switchers and other language-related extensions).

    • This reply was modified 4 years, 6 months ago by Asgaros.

    I’ll tell you the all history.
    I used bbpress before, but than, I realized that your plugin it’s best than the BBPress. However, bbPress still is in my wordpress installation.
    And when I deactivated it (bbPress) my entire site doesn’t work.
    I don’t know if this is something that should happen…
    I’ll try to uninstall all those forum plugins, and see if works.

    Still doesn’t work 🙁

    IT’S WORKING!
    Thanks a lot @asgaros!!

    Plugin Author Asgaros

    (@asgaros)

    Hello @cleudemirjunior

    Happy to hear! What was the reason for this problem? Just in case other people will have the same kind of troubles so it could help them. 🙂

    Yeah!
    So the thing was pretty simple: in my file, instead of a “_” there was a “-” so the file was not recognized by the plugin.
    When I changed one by another, worked perfectly.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Install different language’ is closed to new replies.