Support » Installing WordPress » Install claims I already installed!

  • I am trying to move from one domain to another. I dismally failed, so I decided to start from scratch and delete installation and database with a clean install, uploading with “auto”, not “binary” just to check that the basics are OK.

    Now when I try to install I get:

    hide_errors(); $installed = $wpdb->get_results(“SELECT * FROM $wpdb->users”); if ($installed) die(__(‘
    Already Installed

    You appear to have already installed WordPress. To reinstall please clear your old database tables first.

    ‘)); $wpdb->show_errors(); switch($step) { case 0: ?>

    Obviously I HAVEN’T already got wordpress installed, since I deleted everything, but it seems that the script believes I have?

    What else is there to check?

Viewing 14 replies - 1 through 14 (of 14 total)
  • Whether it has in fact installed or not you can alter wp-config to a new db and go again.

    “Obviously I HAVEN’T already got wordpress installed, since I deleted everything, but it seems that the script believes I have?”
    Apologies if this sounds patronising but are you sure that you have *dropped* the WP tables? Fire up phpmyadmin and doublecheck that this is the case.

    As a quick check you can run upgrade

    I ran upgrade, which doesn’t return an error, and directs me to my blog page, which is blank. which is no big surprise as the db has no tables (I checked)

    Starting again with a new db has the same result.

    Running the script with the name of a db that doesn’t even exist has the same result.

    I’m sort of at a brick wall here as I have no idea how to debug the install script!

    Forgive me BUT. In Config you need to put in the db name but further down there is the prefix option for multiple /sequential installs. Wp does not require a db exactly. It just needs a set of tables. It creates those. Non existent is not meaningful in this context.

    In my config file I have tried:

    dbname for newly created, blank database, with prefix wp, and later with prefix xy
    dbname for database that hasn’t been created yet

    In all 3 cases I get the same error as above.

    As far as I can see, the install script looks in the named database for the prefixed tables and if these exist returns the “already created” error. In this case that doesn’t seem to be working properly as neither database nor tables exist.



    OK. Now we are into (a) a glitch in the download or (b) server error.

    Mark (podz)


    Support Maven

    How exactly are you getting the files from your computer to the server ? What program ?

    I am ftp’ing using Transmit, following the same prodedure I used when I installed it the first time.

    The only thing I can imagine is that it is somehow to do with the fact that both domains reside on the same physical server – that doesn’t make sense, I know, but I’m at a loss to see what could be going on!!

    Yes, thats “great” cause i have exactly the same problem.
    Please Help !!! : /

    while backing up the database from phpmyadmin, did u use the “add drop table” under the SQL structure options? if not then backup the database again with that option selected [read the db backup procedure].
    even though ur tables are blank, but it just works that way. do tell if it helped.

    Thanks for replying.

    As I recall, I did use that option – I was careful to follow the procedure exactly.

    In any case – it now appears that the problem is more profound, as I get this message EVEN THOUGH I HAVE NO DATABASE AT ALL!!!

    If I could find a simple way to demonstrate that this is because of a server glitch I cold ask my ISP to look into it, but as it stands it’s just “a guy has a problem with a complex package” and they (understandably) aren’t helping.

    O.K. in my case the problem was this line in the wp-config.php document:
    define(‘DB_HOST’, ‘localhost’); // 99% chance you won’t need to change this value

    hmm, looks like im proudly part of the 1 % that needs to change this line.
    try to fill in your db host. i
    m fine now. : )

    Hi guys, sorry to join the discution so late. I can see a few other people are having the same problem as me. Ive read through most of this thread and have tried everything with no luck. Could somebody please help me!!!

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Install claims I already installed!’ is closed to new replies.