Support » Installing WordPress » Instal error

  • I just upload to my server and when trying to visit the install.php I get the following error

    Error establishing a database connection

    It ask me.

    Are you sure you have the correct username and password?
    Are you sure that you have typed the correct hostname?
    Are you sure that the database server is running?

    I verified that the database, user and password were entered corectly but got the above error. Please help.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Moderator James Huff


    Did you correctly enter the values into wp-config.php? Can you confirm that you can access your database host with your username and password via your browser?

    Also, if your host is using MySQL v4.1.7 (a flawed release), you will see the error message that you are seeing now.

    This how my wp-config.php reads:

    // ** MySQL settings ** //
    define(‘DB_NAME’, ‘blog’); // The name of the database
    define(‘DB_USER’, ‘author’); // Your MySQL username
    define(‘DB_PASSWORD’, ‘******’); // …and password
    define(‘DB_HOST’, ‘localhost’); // 99% chance you won’t need to change this value

    // Change the prefix if you want to have multiple blogs in a single database.
    $table_prefix = ‘wp_’; // example: ‘wp_’ or ‘b2’ or ‘mylogin_’

    // Change this to localize WordPress. A corresponding MO file for the
    // chosen language must be installed to wp-includes/languages.
    // For example, install to wp-includes/languages and set WPLANG to ‘de’
    // to enable German language support.
    define (‘WPLANG’, ”);

    /* Stop editing */

    define(‘ABSPATH’, dirname(__FILE__).’/’);

    of course the password has been blanked for this.

    PHP version 4.3.9

    MySQL version 4.0.22-standard

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Instal error’ is closed to new replies.