Support » Plugin: WP Social Post And Widget » InstagramAPI\Response\ConfigureResponse: Caption too long

  • Hello dude.

    Thanks for this great (and free) plugin that will help me to auto publish Instagram posts.

    I have a big issue. When I publish a post, each time, I’ve got a mail: InstagramAPI\Response\ConfigureResponse: Caption too long.

    What does it mean? Which caption?!

    Thanks for the help.

    PS: is it possible to make a hyperlink that can be clicked with the option “Show Post Link?”. TU 😉

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author qsheeraz

    (@qsheeraz)

    Hi,

    Reduce the number of characters from 2200 from plugin options. Looks these are exceeding from 2200.

    And about hyperlink, Instagram don’t allow hyperlinks 🙁 only plain text.

    Regards

    Hi Sheeraz,
    I brought the character count to 1000 and then to 500. I still get the “Caption too long” error. Tested over a couple days.

    So what is the correct value we need to specify that works.
    Thanks

    I’m also getting this error message:
    Your post ID 3458 not posted on Instragram due to following reason.
    InstagramAPI\Response\ConfigureResponse: Caption too long.

    My settings are the default 2200. Any suggestions?

    Thanks,
    Graham

    Same error message:
    InstagramAPI\Response\ConfigureResponse: Caption too long.

    This topic should NOT be marked as “Solved”.
    I tried the settings with the default “Show Post Details (words)” (2200), then down to 1500 then 1000.

    Also what is the “Caption” in this error message. It it talking about the post content or an image caption?

    I agree. I have same problem with any very short caption. It should not be marked as “solved”. Solved what?

    Hi there.

    It’s not solved for me anyway. My solution: deactivate the plugin and stop using Instagram as a bot 😉

    Hi guys,
    since this topic was “solved” I have created a new one and the plugin’s author offered a solution that works for me: simply set the numbers of characters to 200.
    Here’s the link to the new topic

    From what I understand, the message error’s wording is just wrong, it has nothing to do with a “caption” (which term only applies to an image) but a mixture of post content, URL, tags etc.

    Hope this helps.

    Thanks for the update. I can’t see a setting for the number of characters; all I see is a setting for the number of _words_, ala:

    Show Post Details (words)
    200
    Number of words in Instagram post. Enter 0 for no description.

    Is this what you mean?

    Thanks,
    Graham

    @greyham Yes sorry, that’s what I meant, “words”.
    The option is Show Post Details (words).
    Try setting it to 200 first. It worked for me.

    Plugin Author qsheeraz

    (@qsheeraz)

    @oh_franck Thanks for sharing the new link here 🙂
    These error messages are from Instagram actually. The plugin posts custom message, post content, URL and hashtags as caption. That’s why Instagram send this error if it exceeds.

    @greyham Yes you got right.

    We are also going to change this and make it default.

    Regards

    Isn’t this words/characters discrepancy really the problem?

    I can’t see an official limit specified in Instagram’s help pages, but many other sites cite a limit of either 2000 or 2200 _characters_.

    Can you change the plugin set the limit units to characters rather than words, since this is how Instagram appears to do it?

    Cheers,
    Graham

    braun77

    (@braun77)

    Hello, I have the same problem, I put the character limit at 200 but the error weighs, I use for my portal both for wordpress and woocommerc Divi Builder to paginate the articles and products in my shop …. you can help me ??
    Web link: https://www.marrone-fratelli.it

    Ciao Max from Italy

    • This reply was modified 4 months ago by  braun77. Reason: error Url
Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.