Support » Plugin: Jetpack - WP Security, Backup, Speed, & Growth » Instagram Widget Connection Problem

  • Resolved roadsidephil

    (@roadsidephil)


    I’m trying to use the Instagram widget at the bottom of this page. When I try to connect my account I get this error: Invalid/missing blog nonce. All core actions require a valid nonce.

    I haven’t the slightest idea what that means or how to fix it.

    Made sure I was logged into Instagram first. And I tried connecting both from Elementor and the standard Widgets page in WP.

    Appreciate any ideas you might have.

    The page I need help with: [log in to see the link]

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Support Fotis

    (@fstat)

    Hi there,

    This is probably caused by a caching issue. Please clear your browser’s cache and try again. I also recommend using a different browser.

    roadsidephil

    (@roadsidephil)

    Thank you.. We’re getting closer but not quite there yet.

    These are the steps I’ve done:
    – Tried it in Edge (secondary browser) with a cleared cache and got “Invalid/missing request nonce.” when trying to connect my Insta account.

    – Went back to Chrome (main browser), cleared cache and it looked like it was working. Took me to the Insta connection pop up.

    – I’m doing this in Elementor. It popped up the Insta window to connect via the API. Then I got a notice about “Do you want to leave this page? Your changes won’t be saved.” Clicked No at first and the widget says “Connecting” and hangs there. Checked the page and the widget doesn’t render.

    – Same sequence, but clicked OK on the “leave this page” notice. It took me over to the standard WP Customizer on the Active Widget Area section. But doesn’t give me any way of doing anything with that Insta widget. It does say there’s a more recent autosave, but reverting to that doesn’t change anything.

    – Going back to the page in Elementor, the widget is still there, but it’s not connected to my Insta account. Clicking Connect again gives me a message like “you previously linked WordPress to Instagram. Would you like to continue with your previous settings?” Clicking Continue sends me on the same adventure as previously.

    Ideas?

    Plugin Support Fotis

    (@fstat)

    This might be a conflict with Elementor or some other plugin on your site. Can you disable your plugins and try again?

    roadsidephil

    (@roadsidephil)

    Ok, it does seem to be an issue with Elementor. I tried it with all the plugins deactivated except Elementor and had the same issue.

    Also tried it with all the plugins activated but on a regular Gutenberg page and it seems to work fine.

    So there’s something about when Elementor tries to connect that it pulls me over to the Customizer page for Widget areas.

    Might be something the JetPack folks might want to talk with them about since it’s such a popular page builder. But I’ll check in with their support and see if there’s a solution.

    Thanks for your help.

    Plugin Support supernovia

    (@supernovia)

    Thank you @roadsidephil. To be clear, once you got it connected properly and re-enabled Elementor, did you run into any issues? Or was it just a connection problem, and once connected you were fine?

    roadsidephil

    (@roadsidephil)

    No, even once it was connected outside Elementor it still wouldn’t work inside. Asked to be connected, the API popup asked if I’d like to use the connection settings it already had. And then it still sends me off to the Customizer again.

    Someone on the Elementor Facebook group said that it could be because of OAuth changes that have been made by Facebook and Insta in the last few days.

    Plugin Support supernovia

    (@supernovia)

    Got it. But as long as you’re not using elementor, the connection works properly?

    roadsidephil

    (@roadsidephil)

    Yes, that’s correct. Runs fine without Elementor.

    Plugin Support Fotis

    (@fstat)

    I suggest contacting Elementor’s support. Maybe they have encountered similar cases.

    Yep, I’m doing that. Thanks.

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.