Support » Plugin: Jetpack - WP Security, Backup, Speed, & Growth » Instagram widget connection error

  • Resolved avifb

    (@avifb)


    Hello,
    I have a problem connecting to my Instagram profile.
    A new window pops up with a single error message: “Invalid/missing request nonce.”
    Clearing browser cache did not work.

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Support Bruce

    (@bruceallen)

    Happiness Engineer

    Hi there,

    While your site is publicly accessible, we cannot access your site’s XML-RPC file:

    http://vgfreak.com/xmlrpc.php

    This file is used by Jetpack and other plugins and apps to connect to your site. It must return the following message:

    XML-RPC server accepts POST requests only.

    You can see a working example here:

    https://jetpack.com/xmlrpc.php

    Since your site returns a 404 error for this page, I would recommend that you check the following:

    1) Can you see the /xmlrpc.php file at the root of your WordPress installation when accessing your site via FTP? If you don’t, then please try re-installing WordPress. You can do this by going to the Dashboard -> Upgrades page, then click the “Reinstall WordPress” button.

    2) Do you use any security plugins that may block access to this file? If so, could you try to disable them? You might also want to check your site’s .htaccess file for any rules that might be blocking access to the xmlrpc.php file.

    3) Does your hosting provider block access to this file? If you don’t find any plugin that may block access to the file on your site, I would recommend that you get in touch with your host.

    Once we are able to access your site’s xmlrpc.php file, you should be able to connect Jetpack to https://wordpress.com.

    Let me know how it goes!

    Thank you for the reply!
    The file DOES exists here:
    https://www.vgfreak.com/wp/xmlrpc.php
    (under the wordpress installation folder “wp”.

    For some reason it cannot be accessed in the regular way.
    Also, my hosting provider offers PHP version (up-to) 7.2 Could that be the problem?

    • This reply was modified 2 months, 2 weeks ago by avifb.

    OK, I edited the .htaccess file and now http://vgfreak.com/xmlrpc.php is available.
    However, I still get “Invalid/missing request nonce.” when trying to connect to Instagram.

    Update: editing the .htaccess file broke my site (the was 404 when trying to access any post).
    I reinstated the old one…

    • This reply was modified 2 months, 2 weeks ago by avifb.
    Plugin Contributor Dan

    (@drawmyface)

    Can you check your URL settings in Settings > General?

    If your WordPress installation is in the /wp/ folder, then the WordPress URL should be http://vgfreak.com/wp

    Can you confirm if that’s set correctly?

    Plugin Support Bruce

    (@bruceallen)

    Happiness Engineer

    Hi, we updated a setting on our end and your Jetpack connection now looks good.

    Can you try the Instagram widget again?

    Sorry to inform that I still get the “Invalid/missing request nonce.” error when trying to connect to instagram.

    Plugin Contributor Dan

    (@drawmyface)

    There still seems to be a Jetpack connection issue on your site.

    I would suggest contacting your host and explaining that we are unable to access your blog via cURL, which is needed in order to use Jetpack on your site.

    You can pass this information onto them:

    1. We checked for access to xmlrpc.php via browser:

    http://vgfreak.com/wp/xmlrpc.php

    That test returned “XML-RPC server accepts POST requests only.” which is a valid result.

    2. We checked via cURL by running the following command from the terminal:

    curl -A "Jetpack by WordPress.com" -is -H 'Content-Type: text/xml' --data '<?xml version="1.0"?><methodCall><methodName>demo.sayHello</methodName><params></params></methodCall>' 'http://vgfreak.com/wp/xmlrpc.php' && echo

    The cURL test returned a 404 error response.

    Please provide this information above to your host so they can correct the server settings and allow cURL access.

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.