Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Support Blog2Social-Support


    Hello @emlaksoruvecevap,

    Thanks for reaching out.

    It seems that your image does not fit the image requirements set by the network.
    We checked the image of the URL which can be seen on your screenshot and we noticed that the image is quite small: 650×302 px

    Please note that the networks can not publish your post if your image is too small. The best size for images in social media posts is between:
    Resolution: 667-1000px x 523-1000px
    Size: less than 1 MB

    Therefore, we recommend to use a bigger featured image in your post.
    Furthermore, we recommend to check your images with our quick checklist which provide you everything there is to know when your image is not displayed in your social media:

    Thread Starter emlaksoruvecevap


    I tried the picture sizes you specified, but it didn’t. I checked the hotlink protection and others on the link you provided and it’s okay. But I still can’t share Instagram. There is no problem on Facebook and Twitter.

    Plugin Support Blog2Social-Support


    Hello @emlaksoruvecevap,

    Thanks for your reply.

    All networks are different and follow different rules when it comes to images sizes. However, we noticed the featured image of your blog post has still the same size: 650×302 px

    You can check the image of your blog post by right-clicking on the page and selecting “Show page information”. Copy the og:image to a separate tab to see which og:image is set. Therefore, please make sure to use a bigger featured image in your blog post.

    Furthermore, please make sure to share your posts in an appropriate period of time and not in short intervals. Please have a look into our guide to make sure that your posts are shared on Instagram correctly.

    Please let us know if this works for you.
    If this still does not work as expected, please do not hesitate to reach out via Help&Support in your plugin.

    Same problem. All other networks post just fine. No longer works for Instagram.

    Shame, I was just about to purchase a license, too. Only need this for Instagram, otherwise I’d just stay with Jetpack. Guess I have to look for another auto-poster that will actually work with Instagram.

    Don’t buy the “your image is the wrong size” excuse, either. Worked before the last two updates, no longer works now. ALL of my images over the last 12 months have been in the 640×480 range, posted without problems. Now, all of a sudden it’s an issue? Don’t think so. Besides, right in the posting information the plug-in states ” Blog2Social will automatically resize your image according to network requirements.” So, image size shouldn’t matter. Good try though.

    Also, tried with images smaller, images larger and images the exact size required by Instagram, none of them work. Something broke in the last two updates of the plug-in, and it doesn’t have to do with image size.

    Plugin Support Blog2Social-Support


    Hello @johnnynumber5,

    Thanks for reaching out.
    We would like to check this in detail for you if this still does not work for you after following our guides. We will gladly support you as best as we can.

    Therefore would you be so kind to send us a link to the respective blog post and your Instagram account? Furthermore, please let us know the date and time you tried to share your post on Instagram.

    Sure. You can find the Instagram account at

    Here is the latest one I tried to share that didn’t work:

    Here is the last one that was successful:

    Note that the last successful post to Instagram above worked 2 weeks ago, before your latest updates. I tried to post this one again yesterday, and it failed with the same “The network could not publish your post” error that has only appeared since the last to plugin updates. Nothing has changed on the sites except updating the plugin.

    Problem solved on my end. Apparently my CDN did an update and blocked all occurrences from your IP address. I created a whitelist rule to allow the listed IP for Blog2Social and ran another publishing test.

    It posted to Instagam this time.

    Still not sure what caused the auto-block, but I have a workaround for now.

    I have same problem 😂
    Can you add the solved steps

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Instagram, The network could not publish your post’ is closed to new replies.