Photonic Gallery for Flickr, Picasa, SmugMug, 500px, Zenfolio and Instagram
[resolved] Instagram gallery column count (6 posts)

  1. upthejunction
    Posted 3 years ago #

    Seems to me that when using an instagram gallery (I've not tried others), specified columns needs to be one more than required number of columns.

    Eg: columns='4' gives me 3 columns displayed.


  2. Sayontan Sinha
    Plugin Author

    Posted 3 years ago #

    Do you have a page where I can see this happening?

  3. Sayontan Sinha
    Plugin Author

    Posted 3 years ago #

    Never mind, I believe this is your link: http://www.westkirby.org/.

    The problem is not that Photonic isn't respecting the column count - it is that your theme's CSS adds some padding and margins to the list elements in a widget that space things out too far, pushing the last thumbnail to the next row.

  4. upthejunction
    Posted 3 years ago #

    My CSS knowledge isn't great so I could still be wrong, but even using the default wordpress twenty12 theme I have issues.

    See this test only page: http://www.nauticalmodels.co.uk/instagram/

    columns are set to 6, yet 4 columns are displayed. I've tried setting columns to 5 and only 3 columns are displayed. Set columns to 3 and you only get 2 columns.

  5. Sayontan Sinha
    Plugin Author

    Posted 3 years ago #

    What I am trying to tell you is this: if you have an overriding style from some place, I cannot do much about it in the plugin. E.g. in the page you have provided I see this in your style.css:

    .entry-content li,
    .comment-content li,
    .mu_register li {
    	margin: 0 0 0 36px;
    	margin: 0 0 0 2.571428571rem;

    This particular code is messing with the the corresponding Photonic style, which is:

    .photonic-gallery-6c { width: 16%; }

    If you notice, Photonic is trying to apply a 16% width to each list element (which bascially places 6 items in a row), but since the theme is forcing a left margin of 2.57rem, that 16% width is being violated.

    It isn't that Photonic is not respecting your setting - the assignment of the photonic-gallery-**c class is straight from that. But due to the overriding from your theme you are seeing the issue. Here is what you can add to your theme's style.css (or your child theme's style.css) to fix this:

    .photonic-stream li { margin: 0}
  6. upthejunction
    Posted 3 years ago #


    So long I can configure the shortcode to give the required number of columns, by specifying more than I actually want, I'm okay.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic