WordPress.org

Support

Support » Plugins and Hacks » Alpine PhotoTile for Instagram » Instagram feed not found error

Instagram feed not found error

Viewing 15 replies - 1 through 15 (of 41 total)
  • Plugin Author theAlpinePress

    @thealpinepress

    That is strange. I’ll try to look into it.
    Best, Eric

    Hi Eric,

    Thanks so much for looking into it! In the meantime, I’m going to remove the widget since it’s severely slowing down my load time. Please let me know if you need me to put it back for your troubleshooting purposes.

    Thanks again for a beautiful plugin! I’m so excited for it to work again! 🙂

    Best regards,
    Lena

    Plugin Author theAlpinePress

    @thealpinepress

    Can you please try the new update? I have also added a “Plugin Tools” page that should make it easier to identify problems.
    Best, Eric

    Eric!

    That update works like a charm! Everything’s back to awesome!

    Thanks again for your quick help & a great plugin!!
    Lena

    Fixed my issues, I was having the same experience at http://www.landroverlove.com.

    Edit: Same problem, still not loading properly the first time, but if i reload it will find and load…

    Around the world and Driver links.

    Plugin Author theAlpinePress

    @thealpinepress

    Hello,
    I checked your website and saw the problem you described on the Driver page. I noticed that you are using the User Tag option, which I know to be a little problematic. Instagram does not actually let you filter by user AND tag. Therefore, the plugin fetches many photos for the user and then searches the results for the desired tag. Because of this, the plugin may need to contact Instagram 2 to 4 times before it has found enough photos. In your case, I think this is causing the plugin to timeout (maybe your server is a little slow to make the request or Instagram takes a little too long to respond). However, as you have seen, if you try again, things may start to work.
    Recommendations:
    First, I have increased the max fetch time from 10 seconds to 20 seconds (you can delete and re-install the plugin to see if this helps). This might solve your problem but it might also increase the load time. Second, you could try the “Loading Test” on the plugin’s “Tools” page to see if it gives a useful message. Third, displaying fewer images should help.
    Sorry I don’t have the perfect answer, but “sometimes” problems are actually much harder to solve than “every time” problems.
    -Eric

    I am also experiencing this issue. Using the latest plugin I used the test tool and here’s my output. I have not changed anything in Instagram lately.

    [alpine-phototile-for-instagram user="skiwhitefish" src="global_tag" tag="skiwhitefish" imgl="fancybox" style="cascade" col="2" size="M" num="24" highlight="1" align="center" max="100" nocredit="1"]

    Load from the Instagram feed
    
    P0, UTC:18:18:18.6474, Start plugin.
    P1, UTC:18:18:18.6481, Enqueue styles and scripts
    P2, UTC:18:18:18.6483, Retrieve Photos
    P3, UTC:18:18:18.6484, Check cache
    P4, UTC:18:18:18.6491, Using get_transient()...
    P5, UTC:18:18:18.6497, No cache found
    P6, UTC:18:18:18.6497, Check for access_token
    P7, UTC:18:18:18.6498, Try accessing Instagram feed
    P8, UTC:18:18:18.6498, Use wp_remote_get() (cURL) to make request
    P9, UTC:18:18:19.2215, Request complete
    P10, UTC:18:18:19.2215, An error occured.
    P11, UTC:18:18:19.2215, Code: 400
    P12, UTC:18:18:19.2215, Message: Bad Request
    P13, UTC:18:18:19.2215, Failed using wp_remote_get()
    P14, UTC:18:18:19.2215, Check your Instagram feed. If the feed is empty, then the problem is with Instagram. If you see a full page of text, then the problem is with the Alpine plugin or your web server.
    P15, UTC:18:18:19.2216, Check Results
    P16, UTC:18:18:19.2216, Print Message
    P17, UTC:18:18:19.2216, Loading complete
    Output
    
    Sorry:
    
    - Instagram feed not found.

    Ugh. Nevermind. I reset the “secrets” in Instagram under Manage Clients and it’s working again. Sorry to waste your time.

    BUT… my photocentric coworker is miffed because this plugin does not provide “credit” to the user’s photo. Anyway to display the Intagram usertag on the photo overlay from the feed? Thanks!! 🙂

    Link to photo page I’m talking about…

    Plugin Author theAlpinePress

    @thealpinepress

    Sorry, there is not currently a way to show the user, but I do think it’s a good idea. I’m still trying to decide how to add captions, but I am working on it.
    Best, Eric

    I am having the same problem. I just installed this week and it worked fine for a short time. When it stopped working, I tried method 2 and still have an error. http://peaktkd.net/instagram/

    ‘Load from the Instagram feed

    P0, UTC:3:6:4.3575, Start plugin.
    P1, UTC:3:6:4.3591, Enqueue styles and scripts
    P2, UTC:3:6:4.3594, Retrieve Photos
    P3, UTC:3:6:4.3597, Check cache
    P4, UTC:3:6:4.3607, Using get_transient()…
    P5, UTC:3:6:4.3646, No cache found
    P6, UTC:3:6:4.3646, Check for access_token
    P7, UTC:3:6:4.3648, Try accessing Instagram feed
    P8, UTC:3:6:4.3648, Use wp_remote_get() (cURL) to make request
    P9, UTC:3:6:13.4979, Request complete
    P10, UTC:3:6:13.4980, An error occured.
    P11, UTC:3:6:13.4980, Code: 500
    P12, UTC:3:6:13.4980, Message: Internal Server Error
    P13, UTC:3:6:13.4981, Failed using wp_remote_get()
    P14, UTC:3:6:13.4981, Check your Instagram feed. If the feed is empty, then the problem is with Instagram. If you see a full page of text, then the problem is with the Alpine plugin or your web server.
    P15, UTC:3:6:13.4982, Check Results
    P16, UTC:3:6:13.4984, Loading complete
    Output

    Load from cache

    P0, UTC:3:6:13.4995, Start plugin.
    P1, UTC:3:6:13.5011, Enqueue styles and scripts
    P2, UTC:3:6:13.5014, Retrieve Photos
    P3, UTC:3:6:13.5017, Check cache
    P4, UTC:3:6:13.5019, Using get_transient()…
    P5, UTC:3:6:13.5024, No cache found
    P6, UTC:3:6:13.5024, Check for access_token
    P7, UTC:3:6:13.5026, Try accessing Instagram feed
    P8, UTC:3:6:13.5026, Use wp_remote_get() (cURL) to make request
    P9, UTC:3:6:22.6506, Request complete
    P10, UTC:3:6:22.6507, An error occured.
    P11, UTC:3:6:22.6507, Code: 500
    P12, UTC:3:6:22.6507, Message: Internal Server Error
    P13, UTC:3:6:22.6507, Failed using wp_remote_get()
    P14, UTC:3:6:22.6507, Check your Instagram feed. If the feed is empty, then the problem is with Instagram. If you see a full page of text, then the problem is with the Alpine plugin or your web server.
    P15, UTC:3:6:22.6509, Check Results
    P16, UTC:3:6:22.6509, Loading complete
    Output’

    Same exact problem here. I also just installed this week, and it was working fine for a day or so. The debugger tells me I’m getting a 500 error. The site is hosted on Dreamhost.

    System Check

    Check the settings and extensions on your web server.
    Current PHP version of your server: 5.3.27
    Check: curl_init function found.
    Check: Plugin failed to connect to Instagram.com.
    Code: 500, Message: Internal Server Error.

    Check: json_decode function found.
    Check: Sample JSON successfully decoded and parsed.

    The peaktkd.net site is hosted on Siteground, but has the same 500 code.

    It looked awesome when it was working. Have been trying to fix for several hours. Have reset secret. Deleted user, etc, still not working. Very sad as it looked awesome for a while.

    Plugin Author theAlpinePress

    @thealpinepress

    Sorry for the delayed response. Are you still getting this message?

    A 500 error code means that an error occurred on the Instagram side of things. “Worked for a short time” is an important detail. Perhaps Instagram went down for a period of time or perhaps there are other settings that prevent you from receiving data. I would contact your hosting provider and see if they can connect to instagram.com using the cURL php extension.

    Have you tried any other Instagram plugins? If other plugins worked and mine did not, I would appreciate hearing so that I can check what they do differently.

    Best, Eric

    I have tried Yakadada and Justified Image Grid. All 3 are having the same problem. I have the site host checking on the problem and will let you know what they find.

    They claim there is nothing wrong on their end. I am not buying it. I am having the same problem with every instagram plugin I try.

    The only error in the log is this:

    [07-Apr-2014 01:12:17 UTC] WordPress database error Table ‘peaktkd0_wp767.wp_wfPerfLog’ doesn’t exist for query select count(*) as cnt from wp_wfPerfLog made by do_action_ref_array, call_user_func_array, wordfence::dailyCron, wfDB->querySingle

Viewing 15 replies - 1 through 15 (of 41 total)
  • The topic ‘Instagram feed not found error’ is closed to new replies.
Skip to toolbar