Support » Plugin: WP Instagram Widget » ‘Instagram did not return a 200’ once again!

  • Hello,

    I came upon this issue after deleting the transient related. I don’t know if what I did was super wrong, but the widget hadn’t updated in weeks and I thought deleting the transient would force it to “refresh”.
    Now I get this error message but only for @usernames, I tried it with #tags and it works fine.

    Any update on this?

Viewing 10 replies - 1 through 10 (of 10 total)
  • ArwenUndomiel

    (@arwenundomiel)

    Hello, can anyone help???

    Plugin Author Scott (@scottsweb)

    (@scottsweb)

    It sounds like Instagram is blocking the request from your web server. It is hard to know why without further information from the request:

    You would need to be confident in modifying code to debug it further, if you are happy to edit code add:

    
    print_r( $remote['headers'] );
    print_r( $remote['body'] );

    here: https://github.com/scottsweb/wp-instagram-widget/blob/master/wp-instagram-widget.php#L206

    and report back what you see.

    Hi Scott,

    I tried that, since I have the not 200 error for a month now, and this is what I get:

    Requests_Utility_CaseInsensitiveDictionary Object ( [data:protected] => Array ( [content-type] => text/html; charset=utf-8 [vary] => Accept-Language, Cookie [content-language] => en [date] => Mon, 28 Jan 2019 17:22:53 GMT [strict-transport-security] => max-age=60 [cache-control] => private, no-cache, no-store, must-revalidate [pragma] => no-cache [expires] => Sat, 01 Jan 2000 00:00:00 GMT [x-frame-options] => SAMEORIGIN [content-security-policy] => report-uri https://www.instagram.com/security/csp_report/; default-src 'self' https://www.instagram.com; img-src https: data: blob:; font-src https: data:; media-src 'self' blob: https://www.instagram.com https://*.cdninstagram.com https://*.fbcdn.net; manifest-src 'self' https://www.instagram.com; script-src 'self' https://instagram.com https://www.instagram.com https://*.www.instagram.com https://*.cdninstagram.com wss://www.instagram.com https://*.facebook.com https://*.fbcdn.net https://*.facebook.net 'unsafe-inline' 'unsafe-eval' blob:; style-src 'self' https://*.www.instagram.com https://www.instagram.com 'unsafe-inline'; connect-src 'self' https://instagram.com https://www.instagram.com https://*.www.instagram.com https://graph.instagram.com https://*.graph.instagram.com https://*.cdninstagram.com https://api.instagram.com wss://www.instagram.com wss://edge-chat.instagram.com https://*.facebook.com https://*.fbcdn.net https://*.facebook.net chrome-extension://boadgeojelhgndaghljhdicfkmllpafd; worker-src 'self' https://www.instagram.com; frame-src 'self' https://instagram.com https://www.instagram.com https://staticxx.facebook.com https://www.facebook.com https://web.facebook.com https://connect.facebook.net https://m.facebook.com; object-src 'none'; upgrade-insecure-requests [x-content-type-options] => nosniff [x-xss-protection] => 0 [content-length] => 19909 ) )
    

    I hope it helps to find the issue!

    Thanks
    Daniele

    Hi Scott, thanks for your reply.
    I get this whole thing:
    Requests_Utility_CaseInsensitiveDictionary Object ( [data:protected] => Array ( [content-type] => text/html; charset=utf-8 [vary] => Accept-Language, Cookie [content-language] => en [date] => Tue, 29 Jan 2019 15:34:42 GMT [strict-transport-security] => max-age=86400 [cache-control] => private, no-cache, no-store, must-revalidate [pragma] => no-cache [expires] => Sat, 01 Jan 2000 00:00:00 GMT [x-frame-options] => SAMEORIGIN [content-security-policy] => report-uri https://www.instagram.com/security/csp_report/; default-src 'self' https://www.instagram.com; img-src https: data: blob:; font-src https: data:; media-src 'self' blob: https://www.instagram.com https://*.cdninstagram.com https://*.fbcdn.net; manifest-src 'self' https://www.instagram.com; script-src 'self' https://instagram.com https://www.instagram.com https://*.www.instagram.com https://*.cdninstagram.com wss://www.instagram.com https://*.facebook.com https://*.fbcdn.net https://*.facebook.net 'unsafe-inline' 'unsafe-eval' blob:; style-src 'self' https://*.www.instagram.com https://www.instagram.com 'unsafe-inline'; connect-src 'self' https://instagram.com https://www.instagram.com https://*.www.instagram.com https://graph.instagram.com https://*.graph.instagram.com https://*.cdninstagram.com https://api.instagram.com wss://www.instagram.com wss://edge-chat.instagram.com https://*.facebook.com https://*.fbcdn.net https://*.facebook.net chrome-extension://boadgeojelhgndaghljhdicfkmllpafd; worker-src 'self' https://www.instagram.com; frame-src 'self' https://instagram.com https://www.instagram.com https://staticxx.facebook.com https://www.facebook.com https://web.facebook.com https://connect.facebook.net https://m.facebook.com; object-src 'none'; upgrade-insecure-requests [x-content-type-options] => nosniff [x-xss-protection] => 0 [content-length] => 19909 ) )

    I think it’s a geographical issue : i’m from France and i have this message.
    But when i use a VPN from USA, the widget works fine.

    Can somebody else confirm ?

    @scottsweb sorry but do you have any ideas/news? It’s been weeks that I can’t use the plugin….

    Plugin Author Scott (@scottsweb)

    (@scottsweb)

    Not seeing a great deal in the feedback you have provided that points to the problem. I was really hoping to see a HTTP status code in your output which would indicate what Instagram is returning with. Can you check that this is the full output? Viewing the page source might give you more information.

    My hunch is that your host (who are you hosting with?) could either be blocking external requests OR your host is being blocked by Instagram (perhaps there are many WordPress sites all making requests).

    @scottsweb I see. But why would my host start doing that out of nowhere? This happened when I deleted the transient that was created from this plugin for my @username… I believe it has something to do with this, but the transient is not being re-generated… I can double checked with my host but nothing has changed.

    Thank you.

    Do you think if I uninstall the plugin and delete any remaining files/databases and then re-install it would fix this issue with the transient?

    Plugin Author Scott (@scottsweb)

    (@scottsweb)

    I really don’t think it is a transient problem and you are right, it seems unlikley that your host would make a change suddenly.

    The most likely explanation then is that your server IP address has been blocked by Instagram. Try running the plugin on a local WordPress install or different server if possible and see what happens. We have been discussing about this problem here:

    https://github.com/scottsweb/wp-instagram-widget/pull/108

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.