Support » Plugin: Getwid - Gutenberg Blocks » Instagram block has suddenly stopped working

  • Resolved lpezzolla

    (@lpezzolla)


    Hi there, I am using your Instagram Gutenberg Block on a website I manage. I just noticed it stopped working, showing the message “This endpoint has been retired” (I suppose it refers to the Instagram endpoint).
    Are you aware of this? Do you have a timeline for fixing it? I can temporarily remove the block, but I would really like to restore its functionality.

    Thanks in advance,
    Luca

Viewing 15 replies - 1 through 15 (of 19 total)
  • Plugin Author MotoPress

    (@motopress)

    @lpezzolla,

    We are working on this issue and will do our best to fix it asap.

    Noticed the same issue. A new instagram API should be used according to https://forums.mobirise.com/discussion/25139/error-type-oauthexception-code-400-error-message-invalid-scope-field-s-basic

    Hope it can be fixed soon since it’s the only reason why i currently use Getwid 🙂

    Unfortunately, I’m having the same problem. 🙁
    In the latest release (1.6.2) version log you wrote:

    Fixed an issue with Instagram block. You should re-authorize the app in Dashboard – Writing Settings to receive new access token.

    Was this a bugfix for this problem? I’ve updated to this version, but I’m still getting
    a json error when getting the token:

    error_type	"OAuthException"
    code	400
    error_message	"Insufficient developer role"
    • This reply was modified 3 months, 2 weeks ago by speculabilis.
    Plugin Author MotoPress

    (@motopress)

    @speculabilis We are waiting for an approval of the new application for a new API from Facebook. Sorry for the inconvenience.

    Exactly the same problem for me. Tried to re-authorize the plugin with no positive outcome… Too bad 😔

    Same here. But I’ll be patient until it’s fixed. Getwid is awesome! Thank you for keeping up with the good job with this plugin!

    Plugin Support Arsen A.

    (@arsengunner)

    Hi, @jorge_molina and @codimex! We are awaiting for a solution from our developers, which should be provided shortly. Thank you in advance for you patience.

    Regards,
    Arsen

    Plugin Author MotoPress

    (@motopress)

    @codimex , @jorge_molina , @speculabilis

    Update to version 1.6.3 and check if it works for you.
    You should re-authorize the app in Dashboard > Writing Settings to receive new access token.

    Hi,

    After the last plugin update the Instagram block sort of started working for me but not for all the images. Some of them were still missing. I just managed to identify the problem so thought it might be helpful to someone else experiencing the same issue and until MotoPress fixes this in the next update.

    The problem occurs when you create a gallery of images in Instagram, those entries will currently not be displayed by the Instagram block. To get them to display I edited this file:

    {Your WordPress httpdocs-folder}/wp-content/plugins/getwid/includes/templates/instagram/post.php

    and changed line 18 to include the type ”CAROUSEL_ALBUM”:

    
    <?php if ($post->media_type == 'IMAGE' or $post->media_type == 'CAROUSEL_ALBUM') { ?>
    

    That should do the trick for now.

    All the best,

    Erik

    Plugin Support Dmytro

    (@dimned)

    Hi @erikepineer,
    Thanks for your feedback and shared solution. At the moment, Instagram works for single images only. We have added your request to our list of features and notify you when we have any news.

    Hi @arsengunner and MotoPress team. Thank you for working so hard on this. It’s a pity we’ve lost the likes/comments icons, but I guess IG’s new API didn’t make things easy for you guys. Thank you for solving this! At least, we’ve got the block back! 🙂

    I’m experiencing the same issue that @erikepineer described (gallery posts aren’t displayed, not even the first image). I’ll definitely modify the file with your code, hoping that this comes into plugin core in an upcoming update. Thank you, too, @erikepineer! Good job!

    Plugin Support Arsen A.

    (@arsengunner)

    Hi, @codimex! Thank you for your kind words, we will do our best to include the image gallery feature in one of the future plugin updates.

    wpoet

    (@digression)

    Hi,

    I wondered if there is any way of skipping those Instagram image galleries in the meantime, so they won’t show up as empty thumbnails?

    Plugin Support Dmytro

    (@dimned)

    Hi @digression,
    There is no way to skip gallery posts yet. We will notify you if we have any news. Thanks.

    Plugin Author MotoPress

    (@motopress)

    @erikepineer It’s fixed in 1.6.4.
    Thank you.

Viewing 15 replies - 1 through 15 (of 19 total)
  • You must be logged in to reply to this topic.