WordPress.org

Forums

WP Fastest Cache
[resolved] Inserts special characters at top of cached pages (31 posts)

  1. leslamb
    Member
    Posted 1 year ago #

    At the top of cached pages, these characters appear:

    --> --> --> --> --> --> --> --> --> --> --> --> --> -->

    Website is http://www.playandlearnkids.ca

    Thanks!

    https://wordpress.org/plugins/wp-fastest-cache/

  2. JoshuaPack
    Member
    Posted 1 year ago #

    Looks like it is due to the Yoast WordPress SEO plugin. but I could be wrong. I don't think it is due to the WP-Fastest Cache.

  3. leslamb
    Member
    Posted 1 year ago #

    I could be wrong too, but I posted this here because the problem does go away when I disable fastestcache. What is your reasoning, Joshua?

  4. Kramarz
    Member
    Posted 1 year ago #

    when you check the code on your website using ctrl+u and search using ctrl+f for '-->-->-->' for example you will notice this (even shows in red in firefox for me):

    <!-- <!-- <style>.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style> -->
    <!-- <!-- <!-- <!-- <link rel='stylesheet' href='http://playandlearnkids.ca/wp-content/cache/wpfc-minified/cd545966a09cb9df4446610a68c9e1ed/1399738533index.css' type='text/css' media='all' /> --> --> --> --> -->
    <!-- <!-- <!-- <!-- <link rel='stylesheet' href='http://playandlearnkids.ca/wp-content/cache/wpfc-minified/cd545966a09cb9df4446610a68c9e1ed/1399738533index.css' type='text/css' media='all' /> --> --> --> -->
    <!-- <!-- <style>.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style> -->
    <!-- <!-- <!-- <!-- <link rel='stylesheet' href='http://playandlearnkids.ca/wp-content/cache/wpfc-minified/cd545966a09cb9df4446610a68c9e1ed/1399738533index.css' type='text/css' media='all' /> --> --> --> --> -->
    <!-- <!-- <!-- <!-- <link rel='stylesheet' href='http://playandlearnkids.ca/wp-content/cache/wpfc-minified/cd545966a09cb9df4446610a68c9e1ed/1399738533index.css' type='text/css' media='all' /> --> --> --> -->

    So, yes. There's obviously something wrong in there, too many php-comment opening and closing tags result in displaying those too many closing tags on top of your website :-)

    I'mn sure Emre will solve it for you when he's back after 15th!

    Regards

  5. Emre Vona
    Member
    Plugin Author

    Posted 1 year ago #

    Hi leslamb, I got the problem. I will solve and inform you in the evening. thank you.

  6. Emre Vona
    Member
    Plugin Author

    Posted 1 year ago #

    Hi again leslamb, can you send me your theme with zip? fastestcache@gmail.com

  7. woodsio73
    Member
    Posted 1 year ago #

    HI I have the same problem, using Canvas 2 theme.
    http://www.parkticketsorlando.co.uk
    many thanks

  8. Emre Vona
    Member
    Plugin Author

    Posted 1 year ago #

    Hi woodsio73, where can I find it from?

  9. woodsio73
    Member
    Posted 1 year ago #

    Hi,
    its at the top left, you may need to refresh the page for it to show
    > -->

  10. woodsio73
    Member
    Posted 1 year ago #

    Oops sorry, are you asking about the theme??
    Its a Wootheme.

  11. Emre Vona
    Member
    Plugin Author

    Posted 1 year ago #

    can you send me the theme via email please?

  12. woodsio73
    Member
    Posted 1 year ago #

    Theme sent, thanks

  13. Emre Vona
    Member
    Plugin Author

    Posted 1 year ago #

    thank you so much but i couldn't replicate the problem :(

    http://tinyurl.com/kfx3gue

  14. woodsio73
    Member
    Posted 1 year ago #

    thats strange, if i deactivate the plugin it goes away.
    Thanks for your help.

  15. Emre Vona
    Member
    Plugin Author

    Posted 1 year ago #

    %100 the same theme?

  16. woodsio73
    Member
    Posted 1 year ago #

    Im just waiting to check if the web developer incase its changed.
    As soon as I get an answer I will email you.

  17. woodsio73
    Member
    Posted 1 year ago #

    I have noticed that If I untick the first box Cache System the problem stops.

  18. Emre Vona
    Member
    Plugin Author

    Posted 1 year ago #

    because in this case it does not work :)

  19. George
    Member
    Posted 1 year ago #

    I get the same with the Crangasi theme
    http://wordpress.org/themes/crangasi

  20. Emre Vona
    Member
    Plugin Author

    Posted 1 year ago #

    Hi George, propably another thing causes this issue because this theme works well for me.

    http://tinyurl.com/kfx3gue

  21. George
    Member
    Posted 1 year ago #

    Well, maybe it's a conflict with some other plugin.
    I deactivated the plugin (WP Fastest Cache) and it disappeared.
    I had -->--> at the top.

  22. woodsio73
    Member
    Posted 1 year ago #

    I too have deactivated the plugin and it goes.
    How can we roll back to the previous version?

  23. esmi
    Forum Moderator
    Posted 1 year ago #

    @woodsio73: If you require assistance then, as per the Forum Welcome, please post your own topic instead of tagging onto someone else's topic.

  24. woodsio73
    Member
    Posted 1 year ago #

    Esmi I have the same problem since I updated this plugin, Now as we cant find the conflict I think it would be good to roll back. Im not tagging in and I don't believe I should create a new topic...

  25. esmi
    Forum Moderator
    Posted 1 year ago #

    @woodsio73: These forums have guidelines. Please read them. As you will see, one of these guidelines - entitled Where to Post - specifically states:

    Unless you are using the same version of WordPress on the same physical server hosted by the same hosts with the same plugins, theme & configurations as the original poster, do not post in someone else's thread. Start your own topic.

    Please abide by this.

  26. Emre Vona
    Member
    Plugin Author

    Posted 1 year ago #

    I found the reason. Today I will fix it.

  27. George
    Member
    Posted 1 year ago #

    In my case it's caused by the Simple Image Sizes plugin.

    I created a separated topic but failed and created it directly in http://wordpress.org/support/forum/plugins-and-hacks .

  28. Emre Vona
    Member
    Plugin Author

    Posted 1 year ago #

    Hi leslamb, I fixed the problem. I wanna tell you something about the bug.

    <style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>
    <style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>

    In your code, there are two the same style rules in your html source. My plugin comments out them 2 times.

    Can you do the steps below please?

    - Deactive the plugin
    - Remove the plugin
    - remove /wp-content/cache/
    - Download the plugin again
    - Re-install

    and Can you inform me after testing please?

  29. leslamb
    Member
    Posted 1 year ago #

    It worked! Thank-you so much!

  30. Emre Vona
    Member
    Plugin Author

    Posted 1 year ago #

    your welcome :) if you vote me, it makes me so happy.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.